Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to intall Ubuntu 12.04 to my brand new eBay purchased hard drive. Only got the drive today and already it's causing me problems. The seller is a proper proffesional company with 99.9% positive feedback, so it seems unlikely they would have sold me something rubbish.

My old hard drive packed up last Tuesday and so i bought a new one to replace it. Because this was an entirely new drive i decided to install Ubuntu as there was no current operating system.

My computer is an eMachines EM250 netbook. There's no disc drive so i am installing from a USB stick.

The new operating system loads beautifully, and the desktop appears just as it should. When i click install i am taken to the installer which copies the files to about 35% and then displays this:

[Errno 5] Input/output error

This is often due to a faulty CD/DVD disk or drive, or a faulty hard disk. It may help to clean the CD/DVD, to burn the CD/DVD at a lower speed, to clean the CD/DVD drive lens (cleaning kits are often available from electronics suppliers), to check whether the hard disk is old and in need of replacement, or to move the system to a cooler environment.

The hard drive can be heard constantly crackling.

When i booted Ubuntu 12.04 from my old faulty hard drive as a test, i didn't even make it past the purple Ubuntu screen, so it can't be that bad.

Any ideas?


Message to the moderators. Please do not close this thread. I'm well aware there may be other threads on this, but i don't want it closing as the others do not provide the answer i am looking for. Thank you.

share|improve this question
    
i had similar errno5 problem when installing ubuntu live CD with correct md5sum from windows, but worked it around by letting wubi download and install ubuntu together. Not sure if you can try network install for standalone ubuntu. –  sof Nov 4 '12 at 22:11
add comment

2 Answers 2

What fixed this for me was to boot up a live cd of gparted and then delete all the partitions on the drive (and apply).

Restarted and booted up into the install again and it worked as expected.

There's some kind of incompatibility with existing partitions. I'm not sure exactly what it is, obviously, but wiping the drive clean of partitions should do the trick.

I ran into this many times and reproduced this cause/fix several times to make sure I wasn't going crazy.

share|improve this answer
add comment

The 'constant crackling' thing might mean that either the drive is faulty or it's getting less power. Visit the HDD company service centre and get it replaced. Try again.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.