Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I know this question has been tackled in a couple different threads but I've tried what I could from those and have not resolved the issue. I have just a basic understanding of this system so feel free to talk down to me or explain this like you would to a 5 year old.

Let's start from the beginning. My son has a computer built by an IT friend of mine (we moved so he can't help any more). It had Windows XP running on it and it just stopped working correctly. This same friend had built a laptop for me with Ubuntu which I liked so I thought I'd put a new OS on my sons computer and it may work better. I downloaded Ubuntu 12.10 onto a USB drive and loaded it onto his computer. I followed all the prompts, it installed, I restarted the computer, it gives me the option of which OS to pick. I pick Ubuntu and it seemingly loads. The desktop comes up with just the basic pinkish Ubuntu background but that is it. There are no icons. I can't right click anywhere to create a file. Left clicking the mouse does not create a square when moved. Alt + F2 doesn't do anything. I can open a terminal but any of the commands I have seen in previous threads do not correct any issues.

What else can I do, or what resources are available to fix this problem? I don't know if there are additional files on the USB drive that I need to access or what.

Also, one of the problems we were having with my sons computer is that windows would only load to a blank screen. It runs accordingly in safemode and my install of Ubuntu was through safemode of Windows XP.

share|improve this question
    
This sounds like Unity is failing to load... are you getting to a user login window or not event that far? –  cprofitt Oct 24 '12 at 16:47
    
Have you tried the gnome shell via gnome-panel? I find that it is generally very stable and haven't had trouble with it. You can check with sudo apt-cache search gnome-panel and install with sudo apt-get install gnome-panel –  drN Oct 24 '12 at 17:05
    
Thank you for that. I did forget that detail. I am not getting a user login window. And now that you brought it up, when it was installing I never got the option to create a username or password. Is there a way to uninstall and start over, and at the same time take care to not make whatever mistake I made initially? OR if there is an easier solution, I'd be happy to hear it. –  Ric Oct 24 '12 at 17:09
add comment

1 Answer 1

  1. If you're able to boot, but after login Unity doesn't load: It's possible that your GPU drivers are interfering; or that your hw isn't 3d-capable. Please insert the LiveDVD and post the result of the following command (press CTRL+ALT+T) :

    /usr/lib/nux/unity_support_test -p
    
    • If you're using nVidia drivers: Run the following commands to remove them, and reboot:

      sudo apt-get purge nvidia-current sudo apt-get remove nvidia-current-updates sudo apt-get remove nvidia-experimental-304

    Or just install/open Synaptic and search for nvidia, delete everything that you see now.

    Reboot the system. See if everything's working. Run this command to check if Unity-3D will work:

    /usr/lib/nux/unity_support_test -p
    

    Reboot again. Reinstall latest nVidia drivers:

    sudo apt-get install nvidia-current-updates
    
    • If using AMD/ATI GPU drivers: Run the following command to remove them, and reboot:

      sudo apt-get purge fglrx
      

    Don't reinstall them as ATI cards currently don't support Unity-3D.

  2. If you're unable to boot: Insert a Ubuntu 12.10 Live-CD/DVD and run the following commands:

    sudo add-apt-repository ppa:yannubuntu/boot-repair && sudo apt-get update
    sudo apt-get install -y boot-repair && boot-repair
    

    Boot-Repair will launch. Select the 'Recommended Repair'.

  3. IF you fail to see the Grub:- Insert a Ubuntu 12.10 Live-CD/DVD and run the following commands:

    sudo mount /dev/sdXY /mnt # XY is the drive, eg. sda or sda1
    grub-install /dev/sdX #X is drive number
    update-grub
    

    Reboot.

share|improve this answer
    
TomKat - I may not be doing this correctly. I don't have a login page but have tried a couple of your suggestions here and nothing has worked thus far. In regard to option number 3. How do Identify what the Drive and Drive number are? –  Ric Oct 25 '12 at 15:15
    
To find drive/partition identifiers, open disks and select a partition. note the device value. sdXY should be where your root partition is; and sdX is the primary HDD (X=letter; Y=number). –  TomKat Oct 25 '12 at 16:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.