Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got a 12.04 headless server that I've been trying to get to work with wake-on-lan. The card is Marvel 88E8053 using the sky2 module. Although WOL is enabled in BIOS and ethtool shows the card as WOL enabled, it refuses to wake when I send the magic packet. I have verified that the packet is being received OK when the machine is on. The machine does wake OK from a BIOS alarm which suggests it is a network card issue.

I've seen reference to bugs in sky2 that mean WOL fails in recent versions of Ubuntu (and have tried a module conf file as suggested here but to no avail)

So I am thinking the best bet is to replace the ethernet card with one that definitely works with WOL in 12.04 - please could you post your card make and model no if you are using it successfully, along with any tweaks you had to make?

share|improve this question
add comment

1 Answer

Make a backup of /etc/init.d/halt and try out the patch listed at the end of following bug - https://bugs.launchpad.net/ubuntu/+source/ifupdown/+bug/981461

Do a restart and then a shutdown to try WOL.

It worked for me on my HP Proliant server. Hope it works on yours.

tip delete the lines show with a preceeding - sign and insert the ones with + sign. The lines without any sign are just for reference to locate the correct code.

share|improve this answer
    
Hi - thanks for the suggestion. Can you tell me the exact shutdown command you use? I've just tried applying the patch then using "sudo halt -p" but that didn't work –  paulusm Oct 25 '12 at 20:36
    
I tried sudo poweroff. But normal shotdown, using menu also works for me. –  vikas112 Oct 26 '12 at 15:24
    
No, unfortunately this did not work. So I renew my call for people to post cards that work out of the box - are there any? –  paulusm Oct 27 '12 at 10:19
    
Can you also try making rc0 and rc6 entries as described in bug. I had done that as well. –  vikas112 Oct 29 '12 at 14:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.