Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have 64bit Ubuntu 12.10 installed with an Intel® Core™ i5-3570K CPU. I use Chromium. I have installed OpenJDK 7 but whenever I right-click the .jar file and click "open with openjdk java 7 runtime" nothing happens at all. I have tried this with OpenJDK 6 and nothing happens.

Could it be a 64bit conflict? I have also tried a different minecraft.jar and nothing changed. The .jar is set to executable.

Please help.

share|improve this question
add comment

2 Answers 2

Try starting it from the terminal instead using this method:

Open the terminal again Applications > Accessories > Terminal Enter the following commands, substituting 'minecraft_server' with the name of the folder you extracted the server to:

cd minecraft_server
java -Xms1G -Xmx1G -jar minecraft.jar nogui

Taken from http://www.minecraftwiki.net/wiki/Tutorials/Setting_up_a_server#Ubuntu

share|improve this answer
    
I don't understand 'substituting 'minecraft_server' with the name of the folder you extracted the server to:' i just have a file called minecraft.jar in my downloads folder :L –  Chris Oct 24 '12 at 16:06
    
Replace minecraft_server.jar with minecraft.jar. and the downloads folder is at /home/(ur username)/downloads" –  alexander7567 Oct 24 '12 at 20:25
add comment

Use the OpenJDK Java 6 runtime, not the Java 7 runtime. In Nautilus (the file manager), right-click on the file, go to Properties > Permissions, and click the checkbox to allow executing the file as a program.

share|improve this answer
    
Why OpenJDK 6 instead of 7? –  Eliah Kagan Jan 23 '13 at 3:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.