Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Kubuntu Live version and sound card visible in the volume/mixer panel. After installing the permanent version I have a dummy output where my sound card should be, therefore no sound. I re-installed the live version three times and then to permanent but the same problem each time. There is a very brief error on boot up to the permanent version that says:

error. cannot attach card default. no such file or directory.

I'm running Kubuntu 12.04 on a Mac G4 PPC with no other OS.

I'm very new to Linux. I am able to follow instructions to help resolve this, but I'm not familiar with the OS.


Unable to paste into the terminal. I have checked very carefully and there are no typing errors. This is certain :)

When I type the command Iḿ then prompted for my [sudo] password for rob. On entering this the error returned is ¨sudo: rm/etc/modprobe.d/blacklist.local.conf: command not found¨

share|improve this question
    
Thanks. Tried this and it replies ¨command not found¨. I tried 3 times in case of typo´s but same response each time. –  Rob Oct 26 '12 at 22:32

1 Answer 1

Recent versions of Ubuntu have inherited a bug from Debian, where snd-aoa modules are incorrectly blacklisted. If this is the case, the easiest thing to do is to delete the /etc/modprobe.d/blacklist.local.conf file that is generated by the installer ( sudo rm /etc/modprobe.d/blacklist.local.conf ). Also, delete any references to sound modules in the /etc/modules file and see if it works without them.

From https://wiki.ubuntu.com/PowerPCFAQ#Why_do_I_have_no_sound.3F

share|improve this answer
    
Thank you for the advice. I appreciate a walk-through instruction on following the instruction. Sorry, I am very unfamiliar with this level of use. –  Rob Oct 25 '12 at 12:56
    
Open terminal program (kconsole). Type "sudo rm /etc/modprobe.d/blacklist.local.conf". Reboot. Should work. –  rsavage Oct 25 '12 at 16:22
    
@rob can you copy and paste into the terminal? The commands sudo and rm are both very common so I'm sure you have them. If you still have problems then can you give the whole error message please? –  rsavage Oct 28 '12 at 7:27
    
Paste is Shift+Ctrl+v or goto Edit > Paste. You are missing a space after rm. –  rsavage Oct 28 '12 at 22:35
    
Hey presto!! Ok so Iĺl eat my words on the typo.... Worked like a charm. Thank you very much :) –  Rob Oct 29 '12 at 18:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.