Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I used to access internet with my laptop in campus, which require proxy.

My internet at home do not require proxy -or rather I don't know any proxy setting since I always set browser setting to automatic. When I try to access internet at home with ubuntu it always try to access it with my campus proxy. I have no idea with to stop it.

Browsing is no problem. I can change the setting in firefox easily enough. The problem is with installing new software.

Help please?

share|improve this question

1 Answer 1

You could make a bash script for it, for me it sounds easier than setting everything up each time, you could use something like in this site (untested):

function proxy(){
    echo -n "username:"
    read -e username
    echo -n "password:"
    read -es password
    export http_proxy="http://$username:$password@proxyserver:8080/"
    export https_proxy="http://$username:$password@proxyserver:8080/"
    export ftp_proxy="http://$username:$password@proxyserver:8080/"
    export no_proxy="localhost,127.0.0.1,localaddress,.localdomain.com"
    echo -e "\nProxy environment variable set."
}
function proxyoff(){
    unset HTTP_PROXY
    unset http_proxy
    unset HTTPS_PROXY
    unset https_proxy
    unset FTP_PROXY
    unset ftp_proxy
    echo -e "\nProxy environment variable removed."
}
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.