Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I do not have enough understanding of this issue for the moment but please bear with me and I'll edit/improve the question to make it of more general scope as soon as I get proper help and I better understand the matter.

So, I keep my music files on an external (Samsung, fat32) drive and use Foobar2000 with Wine to edit their tags (get tags from freedb, among other things)

Now I cannot do that anymore. The same files can be edited if copied on the desktop.

I guess this is related to the fact that the external drive is auto-mounted with limited privileges: in Thunar its files and folders have a lock/cross/etc (depending on the icons I use)

enter image description here

enter image description here

How to remedy this?

(I'm in Lubuntu 12.04)

Odd thing is that adding a second external drive does not involve the same issue. enter image description here

while their permissions look the same enter image description here One difference between them is that the one with the problem is fat32 and the other is ntfs.

They look like this in gparted

enter image description here enter image description here

Bu this doesn't seem to count: switching them between the two usb slots made them mount both ok, but putting them back in the initial order changed the issue: made Samsung load ok while the other one showed the lock sign. Maybe it's related to the order in which they are plugged...

Even more bizarre is that while the Samsung with music was thus ok, I started to edit the tags of music files in Foobar2000, as intended. After succeeding in doing that for an album, the second would not be edited: the same issue re-emerged. Restarting Thunar I see now that the lock/cross sign went back from the second external drive to the Samsung!!!

How to automount all external devices (also: always and permanently) with full privileges?

share|improve this question
    
could you try to indicate a GUI istead of CLI solution? –  cipricus Oct 25 '12 at 8:16

2 Answers 2

Have you tried

sudo chown -R username:username /media/path/to/drive?

That at least is the basic way of doing it one drive at a time. The -R tag recursively gives your username read write access to all folders and subfolders in the HDD.

Side note:

I also find that if you have used these drives on a Mac before, you may want to disable journaling.

In your mac: sudo /usr/sbin/diskutil disableJournal /Volumes/name-of-my-external-hdd

share|improve this answer
    
to do it one drive at a time is not what i want. also, as presented in the question, replugging and playing with the drive may easily make it fully accessible, in any case far more easy than opening the terminal: i would have to look at your answer and paste stuff , that's my level! (anyway, this looks more like a bug). –  cipricus Oct 25 '12 at 8:20
    
@cipricus Well, you plan on using Linux and shy away from the terminal? That is rather strange.... You will find that terminal is by far the most powerful tool you will ever use. And just as a side note, most of the cures in linux are via terminal so you may want to get comfortable with it! :D There is a learning curve that you will eventually overcome if you want to work with linux! Good luck! –  drN Oct 25 '12 at 8:25
    
thnx dr for the good thoughts and whishes but i'm just playing, not working with it. that's why i'm in (l)ubuntu, because it's better and friendlier than windows, and by friendly i mean this community here including you. i'm aware of the power of the terminal, but don't have the time to go up the learning curve far more than the sudo apt-get stuff. (and I do not think that GUI is incompatible with linux, is it?) all the best. –  cipricus Oct 25 '12 at 8:31
    
also: is your solution permanent for the drive concerned? –  cipricus Oct 25 '12 at 8:36
1  
@cipricus Yes, it hasn't reverted in my case yet... –  drN Oct 25 '12 at 8:59
  1. Connect all HDDs. Run this command to get list of attached devices:

$ sudo blkid

  1. Note the device UUID and TYPE of all the partitions you wish to autmount.

  2. Open the file fstab by running:

$ sudo gedit /etc/fstab

  1. Enter all devices you need to automount

UUID=xxxxxxxxxxx /media/<label> TYPE users,defaults 0 0 Here, is the partition-label, i.e name, you wish to use.

  1. Run:

$ sudo mount -a

All partitions should've been mounted.

Now, run the command for all partitions (except root!):

sudo chown -R username:username /media/<label>

share|improve this answer
    
this does not involve all possible external drives: i want to change the way these are seen in general so as to be all automatically mounted as specified. is this solution permanent at least for the drives involved here? –  cipricus Oct 25 '12 at 8:22
    
Yes, it's permanent for the partitions you add to fstab. By 'all partitions/drives', I meant the ones you wish to mount permanently. –  TomKat Oct 25 '12 at 14:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.