Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I believe i have tried every trick in the book ! I am able to access my router from my ubuntu desktop but not even a single site on the internet. i have installed the drivers for my pci wifi card following this procedure :

Earlier it didn't connect to the internet and kept prompting me for the password. after i installed the driver it got connected ! but now i cant access the internet and can only access my router. i deleted the resolv.conf file. I have also tried the "rkill" command and it shows it is unlocked. I have even tried pinging the ip's & and i get replies from both. I have also added them on my wifi configuration setup on ubuntu desktop. I am new to ubuntu but learning fast :-) These are the things i don't like about ubuntu, the simple tasks are difficult for a person coming from windows. I am using ubuntu 12.10. please reply at the earliest i would be very thankful.

share|improve this question

If you are able to ping you are actually connected to the internet.
You should check your DNS settings. It sounds like hostnames are not resolved correctly.
Check your resolv.conf file for the following line:

nameserver <IP>

Where <IP> should be an accessible DNS-server.
You can apply as DS-IP as well.

share|improve this answer
+1 for a clear answer. I had the same issue on 14.04 which I resolved by removing /etc/resolv.conf and putting in a symlink to /run/resolvconf/resolv.conf. – Dai Jun 26 '15 at 6:33

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.