Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I put the last Ubuntu iso on my USB stick using UNetBootin, after formatting it to fat32. I've already done that before with other operating systems and it worked. I can't actually boot Ubuntu from USB since I get a black screen with the error "Machine check error" on top the an automatic reboot happens. The error appears right after the boot, I can't see anything else before.

I'm using my ASUS X54L latop. Does anybody know how to solve this? Installation from CD/DVD works.

share|improve this question

1 Answer 1

I encountered the same issue in my ZenBook :

  • booting on a live debian
  • trying to boot on the installed system (didn't work, for another reason)
  • retry to boot on the live system => MACHINE CHECK ERROR and no boot.

I tried to boot another live usb key (with grub, not with syslinux) and it worked

Then I retried to boot my live debian system again => it worked

So it just seemed that the machine check error is coming from the fact that your machine is in a wrong state internally, and booting on something else triggered a reset somewhere ... (like in some pci state or ...)

clearly an Asus bug IMHO...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.