Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

I've already went through all possible advices and still cannot start my Atheros AR9285 wireless card.

I have a laptop Toshiba Portege Z830 where the WiFi already worked under Windows 7. But after migration on Ubuntu 12.10. I'm not able get it work.

This is what I see on command lshw

*-network UNCLAIMED     
       description: Network controller
       product: AR9285 Wireless Network Adapter (PCI-Express)
       vendor: Atheros Communications Inc.
       physical id: 0
       bus info: pci@0000:02:00.0
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:c0500000-c050ffff

This is what I see on command rfkill list

0: Toshiba Bluetooth: Bluetooth
    Soft blocked: yes
    Hard blocked: no
1: hci0: Bluetooth
    Soft blocked: yes
    Hard blocked: no

Any idea?

share|improve this question

marked as duplicate by karel, Mark Kirby, David Foerster, hg8, Eric Carvalho Jan 3 at 12:57

This question was marked as an exact duplicate of an existing question.

    
I have exactly the same problem on a Toshiba NB305 netbook here, with the same Atheros wireless chipset. The "hard block" claims that a hardware switch has been used to disable the wireless, but there is no hardware switch to do this! (Ubuntu 12.04LTS, and no matter what kernel I try it says the same thing) – David Gardner Dec 7 '12 at 11:02
    
I'd be surprised if you get anything to work on 12.10. It's been unsupported since May of 2014: wiki.ubuntu.com/Releases – SuperSluether Dec 31 '15 at 18:22

You can start with

lsmod |grep mac80211

which gives you the driver name currently working with your wireless device. AR9285 should be using ath9k by default. But in your case it seems your wireless adapter is not enabled at all. You can try this way

echo "options ath9k nohwcrypt=1" | sudo tee /etc/modprobe.d/ath9k.conf

It's reported the above workaround solves the wireless connection problem on certain Atheros AR928x platform.

share|improve this answer

You can use this command:

sudo modprobe ath9k

to enable the device.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.