Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I would like to remotely reboot my Ubuntu 12.04 LTS server via ssh. I do sudo reboot and I loose connection and the server connection does not reappear. It does not ping.

When I go the the physical computer with a screen attached I see a black screen and hear that the server is still on. I do a hard power off (press power on button for a few seconds) and the server halts. After I press power on the server boots with no problem.

As far as I remember the remote reboot has previously worked on that server.

I wonder if sudo reboot & will help? I suppose I could also try sudo shutdown -r and see if that does any difference.

I have listed an excerpt of /etc/log/syslog below. The last thing it records is the stopping of the logging.

Oct 24 10:14:49 servername kernel: [1354427.594709] init: cron main process (1060) killed by TERM signal
Oct 24 10:14:49 servername kernel: [1354427.594908] init: irqbalance main process (1080) killed by TERM signal
Oct 24 10:14:49 servername kernel: [1354427.595299] init: tty1 main process (1424) killed by TERM signal
Oct 24 10:14:49 servername kernel: [1354427.637747] init: plymouth-upstart-bridge main process (20873) terminated with status 1
Oct 24 10:14:49 servername kernel: Kernel logging (proc) stopped.
Oct 24 10:14:49 servername rsyslogd: [origin software="rsyslogd" swVersion="5.8.6" x-pid="876" x-info="http://www.rsyslog.com"] exiting on signal 15.
Oct 24 10:25:34 servername kernel: imklog 5.8.6, log source = /proc/kmsg started.
Oct 24 10:25:34 servername rsyslogd: [origin software="rsyslogd" swVersion="5.8.6" x-pid="862" x-info="http://www.rsyslog.com"] start
share|improve this question
    
Have you tried both methods you're suggesting ? –  NorTicUs Oct 24 '12 at 9:08
    
Not yet. For every reboot I have to walk to another building to get it restarted. –  Finn Årup Nielsen Oct 24 '12 at 11:25
    
I now I tried sudo reboot & and it did not work. –  Finn Årup Nielsen Oct 29 '12 at 9:44
    
I now also tried sudo shutdown -r now non-remotely, - and it did not work. My last messages are Unmounting local filesystems, Will now restart... and [a number] Restarting system which it obviously doesn't do. –  Finn Årup Nielsen Nov 30 '12 at 15:36
add comment

marked as duplicate by qbi, bodhi.zazen, hhlp, Eliah Kagan, Luis Alvarado Feb 7 '13 at 13:33

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2 Answers

up vote 3 down vote accepted

Others have had the same problem: Why can't I restart/shutdown?

Colin Watson suggests trying different parameters for reboot= in grub.

share|improve this answer
    
And now with GRUB_CMDLINE_LINUX="reboot=b" in /etc/default/grub it seems to work! At least two tests with sudo shutdown -r now got it right back. –  Finn Årup Nielsen Dec 18 '12 at 10:22
add comment

You can also try sudo init6

For more evaluation, you should update the dmesg and syslog outputs , when the server restart.

share|improve this answer
    
I have now tried "sudo init 6" in vain. –  Finn Årup Nielsen Nov 15 '12 at 13:48
    
I do not understand "you should update the dmesg and syslog outputs". I think it is after the logs are shut down that the problem begins. –  Finn Årup Nielsen Nov 15 '12 at 13:51
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.