Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Zotero standalone in 12.10 64bit. Some problems which I managed to fix. The one that remains is an error saying "openoffice.org could not communicate with Zotero. make sure zotero standalone or Firefox are open and set to an online state and try again".

That's when I click any button in the Zotero toolbar in libreoffice. Firefox doesn't open with a the plugin installed and a working internet connection. The Zotero troubleshooting which mentions this error was of no help to me. I find reports about this bug going back as far as 2009 but I haven't found anything of help.

share|improve this question
add comment

2 Answers

I have had the same trouble. This is my system:

  • Linux Mint 13 with MATE 64 bit
  • Zotero Standalone 3.0.8
  • Libreoffice 3.5.4.2 (included with Linux Mint).

That configuration would not work with Zotero. The error was "openoffice.org could not communicate with Zotero."

Solution

  • Use package manager to completely remove Libreoffice.

  • Download the latest version from documentfoundation.org.

  • Unzip it and install it per the Readme text file. It will ask you to open the Libreoffice folders with your terminal, then run sudo dpkg -i *.deb two times - once in the DEBS folder and once in the Desktop Integration folder.

Hope this helps! Like you I had no luck with this at all until I did this re-install of Libreoffice.

share|improve this answer
add comment

I had the same problem after upgrading to Ubuntu 12.10. Actually the solution is quite simple. Just go to the menu TOOLS>OPTIONS and search for the java section. There select the JRE installed, press OK, restart and thats all.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.