Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu 12.04 booted in my first harddisk along with the windows O.S and I use the second hard drive (internal) as a backup . Now I am trying to mount it in the Ubuntu but it is giving a lot of problems. my second HD consist of 5 drive and all are partitioned with NTFS filesystem and all contain valuable data. So how can I mount it in Ubuntu 12.04 without losing any data?
I tried from many ways both from terminal and GUI Utility but I still can't solve it.
Some methods were :

sudo fdisk -l 

Disk /dev/sda: 160.0 GB, 160041885696 bytes 255 heads, 63 sectors/track, 19457 cylinders, total 312581808 sectors Units = sectors of 1 * 512 = 512 bytes Sector size (logical/physical): 512

 bytes / 512 bytes I/O size (minimum/optimal): 512 bytes / 512 bytes
 Disk identifier: 0x00019aa4

    Device Boot      Start         End      Blocks   Id  System
 /dev/sda1            2048    49999871    24998912   83  Linux
 /dev/sda2       185831422   289359871    51764225    5  Extended
 /dev/sda3   *    60000256    60205055      102400    7 
 HPFS/NTFS/exFAT /dev/sda4        60205056   185829375    62812160    7
 HPFS/NTFS/exFAT /dev/sda5       285362176   289359871     1998848   82
 Linux swap / Solaris /dev/sda6       185831424   285360127    49764352
 83  Linux

 Partition table entries are not in disk order

 WARNING: GPT (GUID Partition Table) detected on '/dev/sdb'! The util
 fdisk doesn't support GPT. Use GNU Parted.


 Disk /dev/sdb: 500.1 GB, 500107862016 bytes 256 heads, 63
 sectors/track, 60563 cylinders, total 976773168 sectors Units =
 sectors of 1 * 512 = 512 bytes Sector size (logical/physical): 512
 bytes / 512 bytes I/O size (minimum/optimal): 512 bytes / 512 bytes
 Disk identifier: 0x7da87da8

    Device Boot      Start         End      Blocks   Id  System
 /dev/sdb1               1  4294967295  2147483647+  ee  GPT

--------------------------------------------------------------------------

    sudo blkid

 /dev/sda1: UUID="e5aae23e-e090-420b-9d98-926c062b7976" TYPE="ext4" 
 /dev/sda3: LABEL="System Reserved" UUID="6ABCFC39BCFC017D" TYPE="ntfs"
 /dev/sda4: UUID="D6FC1239FC1213F9" TYPE="ntfs"  /dev/sda5:
 UUID="cc387656-f155-4ad0-bbb3-f4fd24017e62" TYPE="swap"  /dev/sda6:
 UUID="5d5c4746-5953-4207-bb33-8016b8c2e135" TYPE="ext4" 

The second harddrive is not shown while using blkid command and even when I tried to mount it, it provide the error message as : /dev/sdb1 :special device does not exit

So please help me solve this problem.

share|improve this question
    
Possible duplicate? –  Tom Brossman Oct 24 '12 at 7:56
    
The stack traces are different. I'm worried about the warning, how did you partition the drive ? –  NorTicUs Oct 24 '12 at 8:15
1  
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.