Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have to reset my internet connection often to get it to work. When it does work, it's definitely slower than when I'm on my Windows installation. My computer uses an RTL8188CE wireless card from Realtek. I'm running the 64-bit version of Ubuntu 12.10. Power management is not on. I've read on other sites that some people fixed the issue pertaining to this wireless card by downloading and installing the drivers from the Realtek site, but it seems as if that only helped people with 32-bit installations. Anyone have any luck with this specific wireless card?

share|improve this question
1  
Welcome to rtl8188ce-madness. See this answer for the best solution with 12.04: askubuntu.com/a/178098/24489 And no, it is not completely stable (12.04, 64bit).Haven't tried it with 12.10 yet. –  Thomas Oct 24 '12 at 5:43
    
Thanks! How well has it worked for you to mitigate the issues? And is there a PPA or anything I could hook into apt-get, or would I just have to recompile at every stable release? Are you using 3.5 or 3.6? –  Nicholas Ryan Bowers Oct 24 '12 at 5:59
    
I was using one of the linux-backports-modules-cw packages - so no recompile necessary. I upgraded the machine to 12.10 and did not look into this for now. –  Thomas Oct 24 '12 at 6:49
add comment

2 Answers

Putting this into /etc/modprobe.d/rtl8192.conf

options rtl8192ce ips=0 fwlps=0 debug=2

then restart, fixed it for me.

share|improve this answer
    
I had a problem with lubuntu 12.10 using the RealTek RTL818CE, where network manager would say it was connected, but I couldn't actually use the wireless until I disconnected and reconnected (same after resuming from sleep/hibernation). Installing linux-backports-modules-cw-etc didn't help, but the solution offered in this answer did (so far at least). I did leave off the debug=2 option. –  Menachem Feb 10 '13 at 16:43
    
I may have spoken too soon. This did not solve all my issues –  Menachem Feb 14 '13 at 0:43
    
I have this problem in Ubuntu 13 and there is no /etc/modprobe.d/rtl8192.conf file. –  eaykin Sep 21 '13 at 23:20
add comment

I had very poor speed with the RTL8188CE until i disabled hardware crypto:

sudo ifconfig wlan0 down && sudo rmmod -f rtl8192ce && sudo modprobe rtl8192ce swenc=1 && sudo ifconfig wlan0 up

Note: 'swenc=1' means software encoding (default is to use hardware-based).

This sped things up significantly (wget I had running at the time went from 5.83KB/s to 812KB/s upon reconnect after reloading module with swenc=1).

If it works for you, add swenc=1 to the relevant module conf file as an option (for persistence after reboot/module-reload).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.