Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am currently using Gnome Shell on Precise and trying to disable the <Alt>Button1 shortcut for dragging windows. I have taken the following steps.

  1. Pressed Alt+F2, typed ccsm and pressed Enter.

  2. Scrolled down to "Move Window" and clicked it.

    enter image description here

  3. Clicked the <Alt>Button1 button next to "Initiate Window Move".

    enter image description here

  4. Unchecked the "Enabled" box and clicked OK.

    enter image description here

  5. Closed ccsm and restarted it.

Sadly, as soon as I restart ccsm, it appears that nothing has actually been modified since "Initiate Window Move" still seems to be mapped to <Alt>Button1. No matter how many times I perform the above steps and restart ccsm, I still get the same results.

What do I need to do to disable this shortcut?

share|improve this question
  1. Start CCSM.

  2. In the left pane, click "Preferences".

  3. In the right pane, under "Integration", deselect "Enable integration into the desktop environment".

I have no idea what that option does, but after a lot of trial-and-error, I found that worked for me. After that, I was able to get my "Move Windows" settings to stick.

share|improve this answer
I checked and that option was already enabled. I still have the same problem. – Nathan Osman Oct 31 '12 at 21:16
The "Enable integration into the desktop environment" needs to be "DISABLED". Are you sure you DISABLED it? – user103452 Nov 5 '12 at 20:57
This works, but results in some of my other settings no longer working – OneHoopyFrood Aug 28 '15 at 3:11

The problem is that you are using Gnome Shell and Gnome Shell does not run on Compiz, but on Mutter.

To fix this issue, you need to change the modifier key that is used for moving windows in your keyboard settings: enter image description here

share|improve this answer
I tried disabling the one you highlighted but it didn't work. I can still drag windows by holding down [Alt] and dragging them. – Nathan Osman Oct 24 '12 at 3:21

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.