Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Xilinx webPack 10.1 requires 32-bit Linux. Only this old version is compatible with their boards. How to make 32-bit applications work on a 64-bit operating system lists:

  1. Installation of 32-bit compatibility libraries (ia32-libs or Multiarch support)
    I already installed ia32-libs, and it's still not working

  2. A 32-bit chroot

  3. Full virtualization through KVM or VirtualBox No, I don't want to be working from a vm all of next semester, that would be painful and I'd rather just reinstall my whole computer to a 32 bit os; which I don't want to do.

  4. Another option in a pinch is getlibs getlibs It didn't sound like it was the best option based on what I've seen.

So I went off to do #2, and set up a chroot for 32-bit Ubuntu Lucid (10.10). Which is to say I wrote:

description=Ubuntu 8.04 Hardy for i386



I then ran:

$ sudo mkdir -p /srv/chroot/hardy_i386
$ sudo debootstrap --variant=buildd --arch i386 hardy /srv/chroot/hardy_i386

Then I ran:

$ schroot -l

And it showed the proper chroot, but then when I run:

$ schroot -c hardy-i386 -u root

I get the following error:

E: 10mount: error: Directory '/srv/chroot/hardy-i386' does not exist
E: 10mount: warning: Mount location /var/lib/schroot/mount/hardy-i386-80359697-2164-4b10-a05a-89b0f497c4f1 no longer exists; skipping unmount
E: hardy-i386-80359697-2164-4b10-a05a-89b0f497c4f1: Chroot setup failed: stage=setup-start

/srv/chroot/hardy-i386 most certainly exists. I've also tried it replacing all references with hardy to lucid, to no avail. I did set up the chrome os environment: and it had me use something with chmod.

So, can anyone figure out what the problem is?

share|improve this question
I'd back up a little. What error are you getting when you try to run the application? Most cross-arch software issues I've seen can be solved with getlibs – Oli Jan 8 '11 at 2:12
Here is what I get:leif@leif-VPCEB11FM:~/Downloads/webpack$ ./setup Product is not supported on "Linux x86_64" platform. – Leif Andersen Jan 8 '11 at 2:28
up vote 3 down vote accepted

you may try

linux32 ./setup

this helps for 32Bit teamspeak on 64bit servers.

from man: (linux32 is an setarch alias)

   setarch  -  change reported architecture in new program environment and
   set personality flags
share|improve this answer
This worked perfectly, thank you. – Leif Andersen Jan 8 '11 at 22:49

There is a typo on your instructions, on /etc/schroot/chroot.d/hardy-i386 you are using /srv/chroot/hardy-i386 , while for the mkdir/debootstrap you are using hardy_i386 for the directory. That explains the error.

I have just fixed the path at /etc/schroot/chroot.d/hardy-i386, tested, it worked as expected.

share|improve this answer
Thank you for catching that. Fixing that, everything worked fine. I need to look into updating the documentation now. – Leif Andersen Jan 8 '11 at 22:49

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.