Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
How to disable touchpad tapping when typing on keyboard?

I'm using (K)ubuntu 12.04 LTS with a Synaptics touchpad. The palm sensitivity it terrible, whenever I'm typing the mouse suddenly jerks off to a different place. Is there a way to enable/increase palm sensitivity?

share|improve this question

marked as duplicate by mikewhatever, Nathan Osman, con-f-use, Stephen Myall, Ringtail Oct 24 '12 at 13:51

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
@mikewhatever I do not want to disable touchpad tapping. I just want to increase palm sensitivity so that a palm touch is not sensed as a finger touch. Of what I know, it is possible to change the maximum "area of contact" in order to function, but I'm not sure. But I definitely don't want to disable tapping. –  asymptotically Oct 24 '12 at 1:53
    
Alright, let's keep it as a fallback option then. –  mikewhatever Oct 24 '12 at 2:31
    
If this is an "exact duplicate", can someone link me to the question? As I said in my comment, I do NOT want to disable tapping –  asymptotically Oct 24 '12 at 15:14
    
@everyone: I have to disagree that this is a duplicate question. This is a very valid question and becomes more valid with the new supersmooth touchpads which Ubuntu constantly fail to handle properly out of the box. –  Ubuntuser Aug 14 at 17:16

1 Answer 1

up vote 6 down vote accepted

AFAIK, palm sensing is not exposed through the graphical touchpad configuration tool. That said, you could try playing with it by using synclient.

To see what options are available, run synclient -l | grep -i palm

PalmDetect              = 0
PalmMinWidth            = 10
PalmMinZ                = 200

Those are the options I see, so, to activate the palm sensing, run synclient PalmDetect=1, and then experiment with the values of the other two.

   "PalmMinWidth" "integer"
          Minimum finger width at which touch is considered a palm.  Prop‐
          erty: "Synaptics Palm Dimensions"

   "PalmMinZ" "integer"
          Minimum  finger  pressure  at  which touch is considered a palm.
          Property: "Synaptics Palm Dimensions"

When you find the right values, create a startup entry in Startup Applications with a command of the following form:

synclient PalmDetect=1 PalmMinWidth=xx PalmMinZ=yy

...where xx and yy are the desired values.

share|improve this answer
    
Thanks! Exactly what I needed! –  asymptotically Oct 24 '12 at 15:23
    
Seems to work when I test it, but periodically I still get accidental palm touchpad click events that move the cursor. GUess I need to play with the values again since the defaults weren't good at detecting my palm. Crazy these options are not available through settings, somehow. –  noisygecko May 31 '13 at 15:05
    
For my ASUS S-200, which has an ETPS/2 Elantech Touchpad, I found good settings were PalmMinWidth=5 and PalmMinZ=20. YPMV. (Your palms may vary) –  ngm Jul 21 '13 at 9:52

Not the answer you're looking for? Browse other questions tagged or ask your own question.