Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Logitech MX510, 8-button mouse and I wanted all of them to be useful.

I already set up the desired actions using xinput, xbindkeys and xev, and it works. The problem is that now the buttons perform two actions, that is, the previous "system default" and the one I set up manually.

For example, there is a "scroll down" button right under the wheel, and that makes no sense, because for scrolling, there's wheel, AFAIK. I use that button for minimizing windows, but now it first scrolls and then minimizes.

Is there a way I could disable the predefined actions?

Thanks!

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.