Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running off of a thumb drive with very average read/write speeds and automatic update checks makes the bootup far less pleasant. Since I manually update via apt there's truly no need to notify me like on a normal desktop. In older versions of Ubuntu there was an item to disable this behavior. On 12.04 this is no longer the case. would it be the 'unattended-upgrades' item in /etc/init.d? If yes, would simply removing the init script would solve my problem?

share|improve this question
add comment

1 Answer

For any future duckduckgo-ers (yeah, I'm calling it that, sue me), here's a solution:

Enter this in the terminal. It will allow displaying of 'hidden' startup services.

sudo sed -i 's/NoDisplay=true/NoDisplay=false/g' /etc/xdg/autostart/*.desktop

Afterwards, search 'startup applications' in the dash and launch it. It will show a host of options previously hidden. Uncheck the update notifier.

To hide everything back again, run the following:

sudo sed -i 's/NoDisplay=false/NoDisplay=true/g' /etc/xdg/autostart/*.desktop

share|improve this answer
    
Thanks for the tip! Gnome startup time was becoming a major headache for me. –  Ben Davis Apr 11 at 19:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.