Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I ssh into my Mythbuntu box, I get this message:

Welcome to Ubuntu 12.04.1 LTS (GNU/Linux 3.2.0-32-generic x86_64)

 * Documentation:  https://help.ubuntu.com/

New release '12.10' available.
Run 'do-release-upgrade' to upgrade to it.

Last login: <redacted>
$

But I don't intend to upgrade to 12.10, because Mythbuntu recommends using LTS releases only.

How do I suppress the "New release '12.10' available" message? I don't want to be notified until the next LTS release is available.

I've already gone to Update Manager > Settings > Updates and selected "Notify me of a new Ubuntu version: For long-term support versions", but that didn't get rid of this message.

share|improve this question
add comment

5 Answers 5

up vote 17 down vote accepted

The other answers aren't quite right, but combining them put me on the right track.

/etc/update-manager/release-upgrades controls what updates you'll be notified about. /usr/lib/update-manager/release-upgrade-motd generates the "update available" message. The problem is that release-upgrade-motd caches the message, which means that once it's been generated, changing /etc/update-manager/release-upgrades doesn't get rid of the message.

So the answer is:

  1. Tell Update Manager what releases you want to be notified about.

  2. sudo rm /var/lib/update-notifier/release-upgrade-available to get rid of the cached message.


Note: For version 13.04 (and later), the path has changed. So point 2. to get rid of the cached message is now:

sudo rm /var/lib/ubuntu-release-upgrader/release-upgrade-available
share|improve this answer
    
Just for future reference, Ubuntu's update-motd is designed to refresh on login as mentioned in the manpage. –  John Vrbanac Oct 23 '12 at 23:06
1  
@JohnVrbanac, yes, but release-upgrade-motd maintains its own cache of its part of the motd. That's what you have to delete manually. –  cjm Oct 23 '12 at 23:08
    
worked for me! thanks. –  Casey Jan 13 '13 at 3:02
add comment

That message is apart of the "Message Of The Day" (MOTD) system. If you just want to disable the update message:

Step 1:

Use a text editor to open "/etc/update-motd.d/91-release-upgrade"

sudo nano /etc/update-motd.d/91-release-upgrade

Step 2:

Comment out (put "#" in front of each line) all of the code within that file so that it looks like this

#!/bin/sh

#if [ -x /usr/lib/update-manager/release-upgrade-motd ]; then
#    exec /usr/lib/update-manager/release-upgrade-motd
#fi

Step 3:

Logout and log back in.

Step 4:

Done!

That should work for both Ubuntu Server 11.10 and 12.04 LTS

share|improve this answer
3  
This will completely disable the upgrade message. I'd still like to be notified when a LTS release is available. But you did point me to the correct solution, so thanks. –  cjm Oct 23 '12 at 23:04
    
Woops! Sorry I misunderstood. I thought you wanted to get rid of it all together. I generally don't like a bunch of stuff showing up when I first login, so I normally just remove it. –  John Vrbanac Oct 23 '12 at 23:08
add comment

Try Editding /etc/update-manager/release-upgrades

Change Prompt from normal to lts or never;-)

share|improve this answer
1  
That is the current setting (I'm assuming the Update Manager GUI changed it). It doesn't help. –  cjm Oct 23 '12 at 22:45
add comment

What you see is the content of /etc/motd

which is automatically generated by scripts in :

/etc/update-motd.d/

the one you don't like is:

91-release-upgrade

so you can delete it.

Or may be better: edit : /etc/update-manager/release-upgrades

and change : Prompt=normal by : Prompt=lts

So you will only be warned when a new lts is released.

share|improve this answer
add comment

For Ubuntu version 13.04 this has changed slightly, so this will consolidate the information from various other answers and update for newer releases.

- First solution is to modify the upgrades check configuration:

vi /etc/update-manager/release-upgrades

Change Prompt=normal to:
Prompt=never - Never check for upgrades
or
Prompt=lts - Only check for LTS upgrades (only if current release is LTS)

- Alternatively, to remove the check altogether, simply delete the check:

rm /etc/update-motd.d/91-release-upgrade

Finally: After making one of the above changes, the message may still be displaying as the daily check is cached.
Resolve this minor hurdle by simply deleting the cached check file:

rm /var/lib/ubuntu-release-upgrader/release-upgrade-available
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.