Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Ubuntu 12.10, and tied it to my company LDAP. On the login screen, instead of prompting for a password there is just a "Log In" button by my name. I click it, and I am immediately logged in without typing in a password. I checking my User Account options, and "Automatic Login" is turned off. I can also click on other LDAP users accounts, and get in without a password.

There is a local user on the system. When I try to log in as that user, I am prompted for a password.

share|improve this question
add comment

2 Answers 2

It sounds a bit like you don't have a password set for your account. To verify this, try the following:

  1. Head back into the User Account settings
  2. Choose 'Unlock' from the upper right (if my assumption is correct, you should not be asked for a password)
  3. Click on the string of dots next to the 'Password' field
  4. Choose a new password, making sure to leave the 'Current Password' field blank.

If you really didn't have a password set, then you should do now.

share|improve this answer
add comment

I found the problem. I was in our LDAP group with GID 119, which on this system happens to be the nopasswdlogin group. I fixed the problem by changing the GID to another number.
I believe group 119 was the admin group on Fedora when we setup our LDAP a while back.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.