Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

since Ubuntu 12.10 ships only Python 3 by default, I wanted to ask, what steps should be taken to get my »Quickly« application ready for python 3?

I already know about 2to3, but I don't know how to start quickly's quickly run command with python 3 support or how to run my applicaton without quickly. Actually right now I use quickly merely to start my application, because I could'nt figure out how to run a quickly application without quickly run.

I appreciate every answer!

share|improve this question
1  
Ubuntu 12.10 does NOT only ship Python 3! It ships also python 2.7 and python 2.7 is also the default python. –  xubuntix Oct 24 '12 at 6:58
    
hey, thanks for your comment (I noticed that too). Anyhow, I managed to port my existing code over to python 3 nonetheless and will write a blog post or something on what I needed to do :) –  wolfv Oct 30 '12 at 13:35

2 Answers 2

up vote 1 down vote accepted

Port Quickly Python 2.7 to Python 3.x

I am not sure if it was there before I upgraded to Ubuntu 12.10 but now is a bin/<programname> Folder inside the quickly-template code. E.g. <programname>/bin/<programname>. It's the entry point from where the quickly app is started!

In this file it's simple to change the python version: Modifying the first line is enough, e.g. change it from

#!/usr/bin/python

to

#!/usr/bin/python3

and your quickly application is running with python 3! Of course, you'll still have to modify all the project files to work with python 3 instead of python 2.7. I went the manual route and fixed all upcoming bugs, however, tools like 2to3 could potentially aid you.

How to start a quickly application without quickly?

Well it's as simple as running python bin/<programname from your application's folder (the same python file you need to modify for python 3 compatibility).

share|improve this answer

The second part of your question: "How to make you application run without quickly run" is discussed here. The patch to enable that is available as part of the bug report on the issue: Compiling schemas not part of the application template

share|improve this answer
    
Hi thanks for the answer. I was already successful in porting it, so I'll leave my answer here, too. –  wolfv Dec 7 '12 at 9:36
    
To apply the patch to your project, download it and run patch bin/projectname 976817-schemas.patch where projectname is the name of your project, and 976817-schemas.patch is the name of the patch file you downloaded. –  Jonah Mar 27 '13 at 5:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.