Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed Ubuntu 12.10 by keeping the home folders from Linux Mint 13 distribution. The system installed fine, but at the beginning everything was in Chinese (even the text in the Terminal). I managed to solve that by editing some files, but I still get an error whenever a command is not found in Terminal. Here it is:

Sorry, command-not-found has crashed! Please file a bug report at:
https://bugs.launchpad.net/command-not-found/+filebug
Please include the following information with the report:

command-not-found version: 0.3
Python version: 3.2.3 final 0
Distributor ID: Ubuntu
Description:    Ubuntu 12.10
Release:    12.10
Codename:   quantal
Exception information:

unsupported locale setting
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/CommandNotFound/util.py", line 24, in crash_guard
callback()
  File "/usr/lib/command-not-found", line 69, in main
enable_i18n()
  File "/usr/lib/command-not-found", line 40, in enable_i18n
locale.setlocale(locale.LC_ALL, '')
  File "/usr/lib/python3.2/locale.py", line 541, in setlocale
return _setlocale(category, locale)
locale.Error: unsupported locale setting

How can I get rid of this error. It says that it is a locale error, so I guess it might be related to the initial language problem, but I'm not an expert in linux stuff. What is your opinion?

share|improve this question
1  
Cool that you found a solution and decided to share it. Let it stay, no need to delete good information :) –  Bruno Pereira Oct 23 '12 at 19:37
    
This is a perfectly good question, since the crash is separate from the main issue. command-not-found is run when you try to run a command that does not exist (cannot be found). However, I do recommend reporting the bug. If you can reproduce it, I recommend using Apport to send the report. Otherwise, you can still report the bug with the complete error message there (it contains the trace, which will likely be usable by developers to figure out the source of the problem). Before reporting it, please see help.ubuntu.com/community/ReportingBugs. –  Eliah Kagan Mar 21 '13 at 14:34

2 Answers 2

I looked at /etc/default/locale and some of the language options were in Chinese. I removed those and added the following and everything is good now:

LC_ALL="en_US.UTF-8"
share|improve this answer
3  
No need to delete the post. –  hexafraction Oct 23 '12 at 19:31
    
Another solution, which worked for me: sudo locale-gen lt_LT.UTF-8 –  Pius May 24 '13 at 17:42

I had the same problem, but found the following solution over at ubuntuforums:

export LANGUAGE=en_US.UTF-8
export LANG=en_US.UTF-8
export LC_ALL=en_US.UTF-8
locale-gen en_US.UTF-8
sudo dpkg-reconfigure locales
share|improve this answer
2  
It works! Thanks very much. –  Ikbear Apr 4 '13 at 11:28
2  
worked for me too, thx a lot! –  Walialu Jul 19 '13 at 20:22
2  
I can confirm that this is the working solution for 13.10 (x64) –  shredding Nov 4 '13 at 14:10
1  
This work!!!!!! –  GusDeCooL Nov 8 '13 at 19:46
    
It doesn't work for me - but then, I'm using en_GB.UTF-8 Any other suggestions? –  hippyjim Apr 12 at 7:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.