Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to use Spanish in LibreOffice, but it won't work.

The Spain Language Pack is installed. If I enable it, my complete Ubuntu installation is in Spanish, but not in LibreOffice.

I tried to use Spanish via LibreOffice extension, but Spanish is nowhere to be found.

Please help me.

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

I assume you mean you want to use LibreOffice's Spanish-language user interface, and enable its editing features for Spanish (e.g. spell-checking).

  1. Make sure the language packages are installed. To do this, open the Language Support dialog (from the menu or by running gnome-language-selector), click "Install / Remove Languages...", make sure the box for "Spanish; Castilian" is ticked:

    Install Spanish language pack

    Then, if needed, press "Apply Changes".

    Don't change the order of the languages (i.e. leave English on top) in the main Language Support dialog; this means that the default language for all applications will be English.

    After doing this, make sure the packages libreoffice-l10-es (Spanish UI), libreoffice-help-es (if you need the help in Spanish), and a Spanish spelling dictionary are installed. (I'm not sure whether Language Support dialog installs these for you.)

  2. Open any LibreOffice application, and browse to Tools > Options > Language Settings > Languages:

    LO language options

  3. Change "User interface", "Locale setting", "Default currency", and default document language (as desired) to your desired national variety of Spanish, and press OK. (You must close and reopen LibreOffice before the language will change.)

    This will change the language only for LibreOffice, leaving other applications in English.

    If you meant you want the Spanish-language tools (for writing documents in Spanish) but still want the English UI, do the same, but leave "User interface" as English.

share|improve this answer
    
okay, this works...and how I can set that the first "!"(or"?") is a "¡" instead of a "!"? –  criztovyl_needs_help Oct 24 '12 at 7:52
add comment

Is the libreoffice-l10n-es package installed? It will need to be installed for LibreOffice to have Spanish UI. You will also need libreoffice-help-es for getting the documentation in Spanish.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.