Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to downgrade subversion to 1.6 from 1.7, doing sudo apt-get install subversion=1.6.17dfsg-3ubuntu3 does not seem to work, any idea on how to do this without breaking half the instalation? thanks!

share|improve this question

6 Answers 6

up vote 12 down vote accepted

What you could try is changing all your entries in /etc/apt/sources.list to precise, like this

deb http://extras.ubuntu.com/ubuntu precise main
deb http://us.archive.ubuntu.com/ubuntu/ precise main universe restricted multiverse

then run:

sudo apt-get remove subversion
sudo apt-get update
sudo apt-get install subversion

If the install of subversion 1.6 works out for you, then you'll want to revert your sources.list, and to lock subversion at 1.6 you run echo subversion hold | sudo dpkg --set-selections

This type of installation is not highly recommended, but sometimes it's the easiest option. If it runs into all kinds of crazy conflicts, then you're other best option is to just switch back to Ubuntu 12.04.

share|improve this answer
1  
Worked like a charm! thanks a lot, I wanted to stay on 12.10 –  LFAY Oct 25 '12 at 13:35
    
I've did not changed the entries, but simply added proposed entries, so I could choose after in the Synaptic, which vesion I need to install. After, I've locked it. –  Fedir Feb 7 '13 at 12:16

If you have Synaptic Package Manager installed, you can force-downgrade Subversion to an older release. Just look up Subversion in Synaptic, right-click Properties, go to the Version tab and check what versions are available to you.

If you're lucky enough, you will find both an 1.7 version (1.7.5 in my case) and an 1.6 version (1.6.17). Close the Properties window, select Subversion from the list, go to the Package -> Force Version menu item and select the desired version.

If everything worked out fine you'll only need to worry about Ubuntu updating your software to the most recent release. In order to stick to the 1.6 version, you can lock this update: Package -> Lock version. And voila, you're back to good old 1.6 :)

share|improve this answer
1  
Excellent answer, Florin. And welcome to Ask Ubuntu! Keep it up! :D –  Mochan Nov 4 '12 at 1:36
    
I'm only seeing a 1.7 version in the properties, and the 'Force Version' menu is grayed out. What determines which versions are available? –  Quantum7 Feb 20 '13 at 18:58
    
@Quantum7 The same thing in mine. What should I do for other versions to be available? –  Gtx May 1 '13 at 8:50
    
Does not work for me either in Ubuntu 13.10 with Synaptic Package Manager 0.80.2 and subversion 1.7.9-1. –  Юнгвирт Тони Nov 30 '13 at 21:06

I have successfully downgraded to 1.6 by manually downloading the 12.04 svn and dependency packages from http://packages.ubuntu.com. I first uninstalled version 1.7. Then, I installed the Ubuntu 12.04 packages in the listed order.

  1. libdb4.8_4.8.30-11ubuntu1_amd64.deb
  2. libsvn1_1.6.17dfsg-3ubuntu3_amd64.deb
  3. subversion_1.6.17dfsg-3ubuntu3_amd64.deb
  4. subversion-tools_1.6.17dfsg-3ubuntu3_all.deb

    The other solutions did not work for me.

share|improve this answer
    
Thank You very much, for my Linux Mint 14 Nadia installation on amd64 it was the best solution to. –  Fedir Feb 7 '13 at 11:47
    
For subclipse You should download : libsvn-java_1.6.17dfsg-3ubuntu3_amd64.deb –  Fedir Apr 10 '13 at 9:44

svn 1.7 client is fully compatible with svn 1.6 server.

You only need to do

$ svn updgrade working_dir1 working_dir2 ...

And work as always, the upgrade preserve local modifications. See svn help upgrade

share|improve this answer
2  
The problem is when multiple client versions are used with the same working directory. For instance, the current svnkit package (1.3.5) is compatible with svn 1.6, so all my Eclipse workspaces need a 1.6 client to update. –  Quantum7 Feb 20 '13 at 18:33

With the help of the other posts, I think I have a come up with a simpler way to nail it using Synaptic (so first ensure it is installed).

  1. Append the following line to /etc/apt/sources.list:

    deb http://us.archive.ubuntu.com/ubuntu precise main
    

    This will ensure you have at least two versions to select from, i.e 1.7 and 1.6.

  2. Run

    sudo apt-get update
    
  3. Go to the package manager, search for subversion and select it.

  4. From the menu select package -> force-version select 1.6 or right click -> properties -> version select 1.6.

  5. Install the package

  6. Select package again, then menu -> lock version.

    This is to prevent automatic updates to higher versions.

This is it. Good luck.

Recall: This uses the previous answers to provide an easier straight forward approach.

share|improve this answer

Add deb http://us.archive.ubuntu.com/ubuntu precise main to your /etc/apt/sources.list.

Remove your current SVN by apt-get remove libsvn1 subversion.

Purge files if needed dpkg --purge libsvn1 subversion.

Do apt-get update and apt-get -t precise install libsvn1 subversion.

You might want to test your installation first with apt-get -t precise -s install libsvn1 subversion.

share|improve this answer
    
This is almost the same as answer #1. Care to elaborate any added value? –  aquaherd May 21 '13 at 17:59
    
Sure. In the answer #1 subversion dependancies are not going to be removed and therefore it will give a dependency error on installation. I've tried it and that is why I've posted my explanation. Hope that helps. –  Andrei May 21 '13 at 18:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.