Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Until yesterday ubuntu was detecting my wifi network well. I had been working with it for about a month. Now suddenly it detects all other wireless networks except mine. Can you please help me with the solution.

Thank you in advance

share|improve this question
What was the last thing you remember doing (e.g. installed updates or drivers or upgraded ubuntu to a new version)? Restart the wifi router, restart the computer. See if it helps. If you use a usb dongle with a usb extension cable, try without the cable. If you don't use a wifi usb, try with a wifi usb dongle. – medigeek Oct 23 '12 at 16:10
Does it help to delete the connection you have defined for it? Rename it? – John S Gruber Oct 23 '12 at 18:43

I had the same problem. Namely, that Ubuntu 12.04 would detect all other networks except the two networks that I have been connecting without any problem for the past 3 months.

To be precise, Ubuntu would not detect the wifi network automatically nor would it show the network when I clicked the wifi icon on the top right of the Ubuntu status bar.

Since I am a novice at linux/Ubuntu I searched through the Internet, with this questing being the most relative, without any quick solution.

I solved the issue by going to System settings >> Network >> Wireless >> unfolding the drop down menu Network Name (it did not indicate my network there as well) >> select the last option Other... >> then unfold the Connection drop down menu and you will find all the previous network connections you have made.

Another option is to click on the wifi icon on the main status bar, click on the Connect to hidden network and click on the drop down menu Connection where you should find the previous established connection.

It worked for me.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.