Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had 11.10 X86 on my Asus laptop (sandybridge, Nvidia 520M). I had 8 hours' battery life with Bumblebee and Jupiter. Average battery discharge rate was around 10w. Later I changed, not upgraded, to 12.04.1 AMD64. I installed Jupiter. But there is no "restricted drivers" available so I guess Bumblebee will not work. So I removed nvidia drivers. Now I only get 4 hours' battery life. Average battery discharge rate is around 19w. The removal of nvidia driver did not make any difference.

What's the cause? Nvidia video card not disabled or 64b version of Ubuntu?

share|improve this question

2 Answers 2

up vote 0 down vote accepted

Bumblebee does work in 12.04, I have it running on 12.10 64bit on a Lenovo z370 laptop (i5-2410M CPU sandybridge). So I guess you should install it on your laptop, too (just follow instructions on bumblebee-project.org).

Additionally, in my experience, settings in the grub config file has a large impact on battery life, too.

I have

GRUB_CMDLINE_LINUX_DEFAULT="pcie_aspm=force acpi=noirq i915.i915_enable_rc6=1 i915.i915_enable_fbc=1 i915.lvds_downclock=1"

in /etc/default/grub.

Don't forget sudo grub-update after editing.

share|improve this answer
    
I tried to install Ubuntu12.04(i386) on the same machine. After I installed Bumblebee, the battery life doubled. So the problem is just the Nvidia card. But unfortunately I just can not install Bumblebee under 64byte Ubuntu12.04. –  sanz Nov 3 '12 at 14:33
    
that seems strange. why you can't install bumblebee under 12.04 64bit? what is the error message when you try? i my case i never cared about "restricted drivers" stuff, i have the nvidia card almost always turned off for power saving. –  alex Nov 4 '12 at 14:04

try to enable laptop mode tools via synaptic it improves battery life a lot

share|improve this answer
    
I think laptop mode tools is enabled, as I had to edit the blacklist of auto-suspend-USB-ID to make my wireless mouse work properly on battery. –  sanz Oct 23 '12 at 14:56
    
maybe you can do by managing some settings in conf list of laptope tools sudo gedit /etc/laptop-mode/laptop-mode.conf have you tried it? –  polarkatenuchie Oct 23 '12 at 15:05
    
What specific settings do I need? I saw in Powertop that all items are "good" except one, when on battery. –  sanz Oct 23 '12 at 23:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.