Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

tl;dr version: Additional Drivers does not work for enabling a driver in Ubuntu 12.10, however it worked in 12.04.


I upgraded to Ubuntu 12.10 from 12.04 via a live USB. I did a fresh install to avoid any conflicts. From 12.04 I know that my wireless card has proprietary drivers that could be installed via Additional Drivers. I did eventually find additional drivers in the software sources menu, however when I attempt to switch to Broadcom 802.11 Linux STA wireless driver source from bcmwl-kernel-source, it not only does not work, it in fact disables my wireless completely. The only way to revert this is to restart, and revert back to "do not use the device". Then upon another restart, my wireless will function once again. I was curious if anyone else had this issue, and if there was a fix for it as of yet. I looked on launchpad and it may be a potential bug, but I am unsure.

Any help would be greatly appreciated (and sorry for that wall of text). Until then, I'll continue to use my wireless as it is (or revert to 12.04), but I do notice a slower connection without it enabled.

share|improve this question

4 Answers 4

up vote 2 down vote accepted

Work for me=> check this, i hope that resolve your problem

Please run:

lspci -nn | grep 0280

Is your pci.id 14e4:4353? If so,please do:

sudo apt-get install linux-headers-generic
sudo apt-get install --reinstall bcmwl-kernel-source
sudo modprobe wl

Your wireless should now be working.

If your pci.id is different, please post it and we'll recommend a fix.

share|improve this answer
    
Your answer is excellent my friend. I had gotten a new laptop (System76 ftw) to replace my old laptop since it was outdated anyways so I had paid little attention. But when I saw that answer, I booted up that other laptop (since it works fine, just 3 years old) and the stupid linux headers must have been corrupted in some way or another. –  Compt Jan 8 '13 at 22:47

I had the same problem installing 12.04 and 12.10 on a friend's Dell netbook. I installed Linux Mint instead and managed to get it working. Installed 12.10 again this morning and had to go into Software Sources again and re-install the broadcom driver from there - although it was selected when asked on pr-install setup.

share|improve this answer

I managed to install it by installing the broadcom-sta-common first and then install that driver . Hope this help

share|improve this answer

Probably you have to:

It works perfectly for me.

More information.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.