Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been using KMail for a month or two now and have so far had no problems with it. However, today my laptop died after the battery ran out of power, and since then whenever I log in I see a steady 100% CPU use from the following processes:

  • akonadi_mailfilter_agent
  • akonadi_imap_resource
  • akonadi_nepomuk_feeder

Running akonadictl stop kills the processes and returns CPU usage to reasonable levels, but then KMail complains that it cannot run without akonadi. Can I clear some type of cache or other settings to get KMail back on its feet?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

The solution is a bit painful, but I at least got everything back up and running again. Here's what I had to do:

  1. Run akonadictl stop to stop akonadi
  2. Remove everything under ~/.local/share/akonadi
  3. Remove everything under ~/.config/akonadi
  4. Restart akonadi

After restarting akonadi, it took a good 15 minutes to resync everything. However, the CPU usage during the sync was about 40% per daemon, much better than 100%.

share|improve this answer
    
I've been searching for a fix for a LONG time and this actually seems to have done the trick. Thanks Nik! –  JESii Mar 6 '13 at 13:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.