Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Installed LibreOffice, no problems but when I click on LibreWriter it takes 30 seconds before it's ready to go. I played with Memory in Options, no improvement. I unchecked Java, no improvement.

share|improve this question
    
Was that the first time you opened the application? Sometimes it is slow only during the first time, or immediately after some update. –  user7182 Jan 7 '11 at 20:45
    
Could you please be more specific about the question ? You would like to understand why is it taking much longer ? Also please let us know how/where did you get it from. –  João Pinto Jan 7 '11 at 21:30
add comment

5 Answers 5

Try using the systray quickstarter. Openoffice most likely is, and that is why it starts immediately. alt text

share|improve this answer
add comment

This is a known problem, at least on Arch Linux.

The problem is that LibreOffice tries to communicate with a WINS server (provided by Samba, I guess). If you do not have such server LibreOffice waits until the packets time out before continue loading.

Info taken from: https://bugs.archlinux.org/task/22693

share|improve this answer
add comment

Got LibreOffice from PPA. And I would like it to startup faster, afterall Ubuntu comes up faster than LibreOffice.

I don't have that option - Quickstarter.

share|improve this answer
    
why didn't you use your normal account and post a comment? Or you could add this info to your original question. If you don't have that option you may need to reinstall - it should be there. Something must be wrong with your installation. –  RolandiXor Jan 9 '11 at 13:03
add comment

Open a terminal and run

libreoffice

and post back the output from this into your original question.

On my Toshiba U400 laptop (3Gb ram, 2Ghz CPU), that command completes in less than a second with no output to the terminal. I have, like you, unticked "Java", but otherwise, it's pretty much a stock install from the Libreoffice PPA outlined at OMGUbuntu.

share|improve this answer
add comment

I had the same issue with LibreOffcie and OpenOffice all the years ago and thought this was normal. However, since a few days the program start within 3 seconds now.

One of the recent Ubuntu upgrades fixed this.

I am using the stable distribution (12.04)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.