Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to get Juju working in HPCloud; however, I can't figure out what is needed for the authorized-keys in the environment.yml file.

I already read this post How can I configure Juju for deployment on HP Cloud? and tried creating a public key from the private key from HPCloud management console. In addition, I tried creating the a public key and putting that information inside of the environment.yml file, but the status command is stating "server refused to accept connection."

Thanks in advance.

share|improve this question

It needs to be the exact output of your ~/.ssh/, here's mine as an example:

type: openstack
default-series: precise
authorized-keys: |
  ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAABAQCuzAhXssdiPaxQ9mEXd6VnRcqhkrJMgt0kQi8FmQgNbO0hKaGfEcdTYbCaA4V37iWwIXSosfkSZ4oglZvbz9dBs6zRC/sObVXGr5DCq58UY7W1LgEF+nSprAGZZs+lJTqs+KNnB8cnJ3Drs2peTNOnlCmCw4zbuAO2ftNuWzaVJRpX5IJae/lxr0B9fbtlQtEcWREUeJRHNi5koQO583TEg0ViyFV6MK+o3SM1FKeXxXaQ/94vJx8Of/CbUnBOyXOUG0p8FK3gyhlsbdsEdRXzYzQ5L1lES+44oujlMHN/+vVw0OMmeMGpnMx2NeFp/tN6y7nvoFjx+Wduzaiwl2RX jorge@lowgirl

Make note of the |, I think you need it.

share|improve this answer
hmm.. I tried your suggestion; however, if I don't quote the string the parser has a problem parsing the file and if I quote the suggested output I have the same problem as I initially had. – Derrick Oct 23 '12 at 13:19

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.