Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Can't google out the solution through some time so I'm asking here.

I have installed Linux Ubuntu 12.04 LTS in virtual box hosted by Windows 7 64bit

Simple >>>my 3D stopped working after some kernel headers update<<< few months ago. Just like that. I don't member which version was it.

In meantime there was 2 or 3 new releases of VirtualBox which I have installed. Every time I am updating VirtualBox Guest Additions to the newest version.

My 3D in Ubuntu still doesn't work.

root@pjadmin-VirtualBox:~# /usr/lib/nux/unity_support_test -p
OpenGL vendor string:   VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 0x300)
OpenGL version string:  2.1 Mesa 8.0.2
Not software rendered:    no
Not blacklisted:          yes
GLX fbconfig:             yes
GLX texture from pixmap:  yes
GL npot or rect textures: yes
GL vertex program:        yes 
GL fragment program:      yes   
GL vertex buffer object:  yes   
GL framebuffer object:    yes 
GL version is 1.4+:       yes
Unity 3D supported:       no

My graphics card in PC is ATI 6850. Please help.

share|improve this question

Ok guys. I have solved the problem.

This are some steps I made to fix it.

  • Uninstall the guest additions ( again ... )
  • Restart
  • After restart I went into System settings -> Additional Drivers and I enabled virtual box driver ( It starts downloading guest additions ). When I tried to install it from the VirtualBox menu ( Install guest additions ) it didnt work.
  • After another restart the name of this driver has been changed into Oracle VM VirtualBox Additions for Linux Module

NOTE that when I tried to disable / enable drivers with installed guest additions system crashed ( only reset helps ) and refused to start. ... and most cofusing ... it was looking enabled.


share|improve this answer

This instructions are given for this setup:

Host 64bit system (Windows 8)
Guest 32bit system (Ubuntu 12.04.2)

After installation of ubuntu you can get a problem with low graphics mode error and that problem is resolvable with updating system from console interface


I think I have solution for installing Guest Additions on Ubuntu 12.04.2 that can help with some driver issues

I prefer to do all the job in terminal Ctrl+Alt+T, will launch it

Saw a lot of people saying that you have to disable 3D acceleration before launching the machine.

Main thing to do on fresh install in virtualbox with ubuntu 12.04 - do all updates

sudo apt-get update


sudo apt-get upgrade

when this will be done

sudo reboot

when system boots again do this

this will update headers

sudo apt-get dist-upgrade

and then

sudo reboot

Done with updates and upgrades

Now you need to prepare you system for installing Guest Additions

Firstly remove all preinstalled stuff from virtualbox

sudo apt-get remove --purge virtualbox*

Then install essential soft for installing Guest Additions

sudo apt-get install dkms build-essential

This step is just to check that headers are correctly installed

sudo apt-get install linux-headers-$(uname -r)

Just in case reboot

sudo reboot

Further, please note I had to install fglrx driver here (I have RadeonHD 5650), otherwise after installing Guest Additions I could not boot into the system

Now we will install guest additions

While you Virtualmachine's windows is active:

Press Host+D or Devices - Install Guest Additions

cd /media/V {only type capital V and hit TAB it will autocomplete}

Now the installation

sudo ./VBoxLi {hit TAB here as well it will autocomplete}

after do this

sudo reboot

This should work. Solved my problems

Don't forget to shutdown and turn on 3d acceleration in settings

Give a message about the result

I hope it helps


share|improve this answer

The many steps in the other solution may work. But before you do all that, you may want to try this simple little fix. I spent hours trying to solve this.

If you you have "mouse trails" enabled for your mouse in Win 7, turn it off.

Control Panel: Hardware: Mouse: Pointer Options Tab - Display Pointer Trails

In my case the mouse disappeared when going full screen.

Ubuntu 12.04 LTS Server Ubuntu 13.04 Desktop Windows 7 64-bit

These are the conditions that produce the error for me. VirtualBox has 3D Acceleration enabled (if you uncheck it, the problem goes away but you lose 3D).

Guest Additions installed (any version from 4.2.10-4.2.18 in my case).

There is no problem if window is scaled less than full screen, but as soon as you enter Fullscreen mode (Ctrl-F) the mouse disappears.

Turning off the Display Pointer Trails in Windows fixes it.

Also used this to get the icons and the left loader bar back.

menu bar and launcher missing in ubuntu 13.04

share|improve this answer

I solved this by using an external device, like a pc controller with analog sticks, then mapped the mouse directions to the right analog stick, and you could map left and right mouse click to two buttons using a free program Joy To Key. At least that way, when you turn off mouse integration in virtual box, you can move the pointer around with the controller instead. It fixed the issue.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.