Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

While upgrading from 12.04 to 12.10 the upgrade crashed while installing the upgrades. It stopped while "configuring python3-aptdaemon.gtk3widgets" and the terminal says flashplugin-installer: downloading then shows the url for the flash plugin that its downloading.

I think it stopped working because my internet connection is a bit patchy, and it probably failed while downloading the installer, but what can I do to make it get going again?

share|improve this question

You can give a try to fix your problem using Recovery Mode if none of the method works for you. If you are using wired connection then no problem, for wireless connection I'm not sure whether it will work or not, because I never tried to enable network in Recovery Mode when using wireless connection. Although you can give it a try.

  • When your system starts chose Recovery Mode (2nd option in grub menu).
  • From the Menu just go to Grub option, it will give a message like Updating grub will mount your system in read/write mode. Just chose yes to mount your system in read/write mode. It will update your grub and will exit from Grub menu.
  • chose network option it may enable your network.
  • Then chose dpkg menu from the list, chose yes for all.
  • Finally chose root option and login. Execute following commands one after another:

    # apt-get autoremove
    # apt-get autoclean
    # apt-get update
    # apt-get -f install
    # apt-get dist-upgrade
    # apt-get upgrade

    Then reboot your system and check whether your issues are fixed or not. Run this command to reboot:

    # reboot

Reply if something goes wrong.s

share|improve this answer

If the update is still running I would stop the internet connection for some seconds. That should result in an error in configuring the flashplugin-installer package, but it should continue with the others.

Then you'll just have to run sudo dpkg --configure -a after the update (with working internet connection) and the flash plugin will be updated.

share|improve this answer

In my experience, it's better to do a completely fresh install, because even the 'leading' Linux-based system will break at dist-upgrade.

Also, in my experience, at the 'sudo apt-get upgrade' stage, flashplugin-installer ALWAYS fails to download the .tar.gz from the Canonical archive, and nothing has ever been done to resolve this issue, in the several years that I've been using Ubuntu.

Furthermore, 'sudo dpkg --configure -a' has no effect.

Start all over again, and hope that the downloads don't fail, just for once.

Is anyone at Canonical listening?

share|improve this answer
This does seem like an excessive amount of work to upgrade... one of the bigger advantage of Linux of previous years was that upgrading was fairly easy: now it seems that Windows/OSX are going forward while Linux goes backward – Jon Story Oct 10 '15 at 22:47

Keep in mind that upgrading to new release can take a long time depending on files and settings you have. There was a bug with python 3 with me upgrading to 12.10 while it was in early beta. If you decide to stop upgrade process i would try intalling aptitude cause it works better with dependencies then apt-get and finish upgrading

  • sudo apt-get aptitude and run sudo aptitude safe-upgrade

Also try

  • `sudo apt-get update -f && sudo apt-get upgrade -f


  • sudo apt-get dist-upgrade && sudo apt-get -f install

When upgrade failed for me once i booted to restore system mode in grub menu and after enabling network i fixed broken packages for upgrade to finish its process and everything worked fine

share|improve this answer
How do I fix the broken packages for the upgrade? And how do I stop the upgrade that's running now? – Mike Oct 23 '12 at 10:41
If you are sure that upgrade 100% stucked and nothing happens then you can close it and follow commands.But be aware upgrade can take hours depending on amount of files and settings you have.If its stucked for sure then use this to fix broken packages try: sudo apt-get update -f && sudo apt-get -f install . Or via synaptic manager- fix broken packages -in menu.Also you can use restore option in grub( press shift to appear at startup screen)there are option to fix it to continue upgrade you ll have to enable networking too so itll finish upgrade. – polarkatenuchie Oct 23 '12 at 10:48

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.