Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just got a new laptop, an Asus ultrabook, and installed 12.10 on it. The installation went smoothly with no errors.

The one issue is that wifi is not enabled by default when I boot. I have to manually enable it after logging in by clicking on the icon in the Gnome panel and selecting "Enable wireless".

Also, if ever the laptop goes into suspend mode, when it comes back, the wifi is disconnected.

After a search on the web, it seems that the problem should be solved by editing the connections, and ensuring that for every wireless connection the "Connect automatically" and "Available to all users" checkboxes are checked. I have done this, but it has not changed anything.

I would like the wifi to always be connected by default, when booting or any other time. How can I get this to happen?

To be clear, I am connecting to a wireless LAN connection, sometimes on my home connection, and sometimes at a hotspot. This is not a 3G or cellular service connection.

share|improve this question

closed as too localized by fossfreedom Oct 27 '12 at 9:16

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
OP flagged this "Turns out this was the result of a hardware problem. To be accurate, the laptop required that I enable wifi by pressing Fn+F2, which I had not realized was an option. So, since it's particular to the laptop, not Ubuntu" –  fossfreedom Oct 27 '12 at 9:15
add comment

1 Answer 1

Check that you've got the configuration to connect automatically:

  • Right click on the Network manager icon
  • Click on 'edit connections' in the drop-down menu
  • Click on the 'Wireless' Tab
  • Select your connection and click the 'edit' button
  • Up the top left click on 'Connect automatically' and down the bottom left click 'available to all users'

If this doesn't work then it seems there may be a problem with Network Manager and the configuration. You could try removing Network manager and the configuration completely and re-install

sudo apt-get purge network-manager
sudo apt-get install network-manager

Note that you will have re-configure the connection afterwards. To re-install you will need a wired connection to plug into so that it can download and install network manager. I'm not sure, but when you remove network-manager it will most probably stop all related services and disconnect from the network.

share|improve this answer
    
Are "wifi", "wireless", and "mobile broadband" the same thing? –  Dave M G Oct 24 '12 at 3:51
    
I think the terminology is open to interpretation. "Wifi" and "wireless" are often used to refer to a local wireless network using a wireless router. I prefer to use the terms "wireless internet" or "mobile broadband" to refer to 3G type services because it can not be confused with local wireless type connections. The problem we are discussing here appears to be the mobile broadband connection problem, not a problem with the wireless LAN card. –  fabricator4 Oct 24 '12 at 10:09
    
I think you might be talking about something different than my issue then, as my problem is with a wireless connection to a LAN. I'm not connecting to a 3G network. –  Dave M G Oct 24 '12 at 11:07
    
See the changed instructions –  fabricator4 Oct 24 '12 at 19:26
    
Note that it's not good enough to simply plug in an ethernet wire to get internet connectivity after uninstalling the network manager. Once I purged the network-manager, it was not possible to download it again even with a wired connection. I had to run sudo dhclient eth0 as explained here. –  Dave M G Oct 24 '12 at 23:24
show 1 more comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.