Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Gnome Classic and it tends to move windows to the edge of screen without my will.

  • I can't leave a window partially off-screen (it moves into the screen once I've switched to another app)
  • Sometimes Nautilus window placed in center of the screen moves down to the edge of the screen again and again.

Where is the magic checkbox to stop that?

Update. The problem is in Compiz plugin "Place Windows". Is there any replacements for that plugin? I want new windows to appear in screen center - that's all what I need from that plugin.

share|improve this question

2 Answers 2

As you can read here:

Disable auto maximizing windows

you have to do install CCSM:

sudo apt-get install compizconfig-settings-manager

After installation, launch it and go to panel for configuration of the plugin Grid.

Select the tab edges, then look for the resize actions and set, as you prefer, the values of corners and edges of your screen.

To settle things once and for all, I suggest you to disable Grid plugin.

share|improve this answer
    
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  fossfreedom Oct 23 '12 at 10:48
    
Thanks for the reference to ccsm (it was difficult to find how to run it when installed, so I'll leave it here: ccsm command). But Grid does not affect the problem I've mentioned. There's a Put plugin with "Avoid Offscreen" checkbox, but it was already disabled. So the problem remains. –  Pavel Koryagin Oct 23 '12 at 11:34
    
I found. The plugin is called Place. But seems it does not have a setting for this weird behavior. If I'm disabling the entire plugin, new windows appear under the Gnome Panel. If I'm enabling it the originally mentioned problem appears. Any ideas? –  Pavel Koryagin Oct 23 '12 at 11:40
up vote 0 down vote accepted

This was a bug. Fixed at least in Ubuntu 12.10

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.