Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

two issues when using the fglrx driver:

when i move to the propriety fglrx driver, unity does not load the side bar. the login screen loads (with top bar displayed), but when logging in, the unity side bar does not load. i can right click the desktop and create new folders. i can ctrl+alt+delete and manage to get to system settings (where i can change back to open source driver).

any ideas?

other issue: when using the fglrx, when i open a panel say system settings), and move the panel, it lags, it moves at like 2 fps, instead of being a smooth move such as when using the open source driver.

any ideas?

specs: i3 4gb ram radeon 5770 hd 512mb gpu (sapphire) 250 gb sata gigabyte h55m mobo.

share|improve this question
Please post the result of the following command: /usr/lib/nux/unity_support_test -p – TomKat Oct 23 '12 at 8:14
Hi Tomkat, when i do this using open source driver, all answers are yes! when i am using fglrx, i do not know how to open a terminal to run this command, do you know how I can? – Adam Oct 23 '12 at 9:11
Terminal can be opened by [CTRL]+[ALT]+[T] or [ALT]+[F2] – TomKat Oct 23 '12 at 9:27

see if ubuntu unity plugin is enabled in compiz config settings. Also try unity --replace command in terminal for 12.10 and unity --reset for 12.04 also you could try reseting compiz to default

share|improve this answer

Are you on 12.10? In that case this is a known bug. Please go to and report that it affects you too (the option is near the top of the page).

You can remove the fglrx drivers and revert to the open source drivers (which should work) by following the instructions on or via the system settings, like you mentioned.

share|improve this answer
thanks guys i have gone to 12.04 and fglrx installed and working. could be the same bug. thanks! – Adam Oct 24 '12 at 12:49

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.