Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Every time I try to install "WINE" VIA the Software Center on Ubuntu 12.10, I get this error:

The following packages have unmet dependencies:

wine1.4: PreDepends: dpkg (>= 1.15.7.2~) but 1.16.7ubuntu6 is to be installed
         Depends: libc6 (>= 2.14) but 2.15-0ubuntu20 is to be installed
         Depends: wine1.4-amd64 (= 1.4.1-0ubuntu1) but 1.4.1-0ubuntu1 is to be installed
         Depends: wine1.4-i386 (= 1.4.1-0ubuntu1) but it is not going to be installed

When I try installing it VIA the terminal, this is what I get:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine1.4 : Depends: wine1.4-i386 (= 1.4.1-0ubuntu1) but it is not installable
           Recommends: gnome-exe-thumbnailer but it is not going to be installed or
                       kde-runtime but it is not going to be installed
           Recommends: ttf-droid
           Recommends: ttf-mscorefonts-installer but it is not going to be installed
           Recommends: ttf-umefont but it is not going to be installed
           Recommends: ttf-unfonts-core but it is not going to be installed
           Recommends: winbind but it is not going to be installed
           Recommends: winetricks but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

how do I fix this?

share|improve this question
    
Which Ubuntu version are you using? –  To Do Oct 22 '12 at 20:55
    
12.10... I should probably add that to my question... –  pgrytdal Oct 22 '12 at 21:04
    
When installing wine1.4 on ubuntu 13.10, Everything goes great until somewhere along the way, it pops up a message in the terminal window that can't be gotten past. It's asking for an OK relating to EULA. It's needing input from some other source, not the keyboard. To get around it, I then have to run dpkg --configure -a to clear the situation. What am I missing here. The original command (logged in as root) # apt-get install wine1.4 winetricks. Runs for perhaps a minute or two, then pops this message up (I can scroll the messsage, which takes several pages, down to the "<"ok">".) Nothing –  Hal Hackney Apr 6 at 19:25
    
possible duplicate of Why is Wine not installable on my system? –  Eliah Kagan Aug 28 at 14:40

6 Answers 6

up vote 5 down vote accepted

I tried to make the multiarch file as @dchampagne suggested but it didn't work. To get it to work properly I had to do this:

sudo dpkg --add-architecture i386

That cleared everything up for me. Looking elsewhere on the interweb this is apparently a really common problem with 12.10.

share|improve this answer

First

sudo dpkg --add-architecture i386

after that

sudo apt-get install ppa-purge
sudo add-apt-repository ppa:ubuntu-wine/ppa && sudo apt-get update
sudo apt-get install wine1.5

This solved my problem.

share|improve this answer

I had to combine a few posts to make it work, but here's what helped me successfully:

sudo apt-get install ppa-purge
sudo add-apt-repository ppa:ubuntu-wine/ppa && sudo apt-get update
sudo apt-get install wine1.5

I'm running Ubuntu 12.10 via Windows install.

share|improve this answer

I had the exact same problem. Heres what I did to get it to work:

  1. Create a file named multiarch in /etc/dpkg/dpkg.cfg.d and use a text editor to put the following line in the file: foreign-architecture i386. This will let you install the i386 package wine depends on.

  2. Do sudo apt-get update and then try installing wine.

share|improve this answer

try

  • sudo apt-get update -f && sudo apt-get-f install

or

  • sudo apt-get install aptitude && sudo aptitude safe-upgrade

Or remove wine ppa from software sources ( other software in update center)and

  • install it via ubuntu tweak programm search for 'playonlinux'
  • You can install synaptic pack manager and install wine package

search for dependencies and install them via gdebi manager sudo apt-get install gdebi open deb with it.Example Depends: wine1.4-amd64 here is link to it with all wine dependencies

- updated

purge wine ppa,to purge ppa you need to install ppa-purge by this sudo apt-get install ppa-purge then execute

sudo apt-get ppa-purge ppa:name 

FOR EXAMPLE sudo ppa-purge ppa:tualatrix/ppa Then install playonlinux

  • sudo wget http://deb.playonlinux.com/playonlinux_precise.list -O /etc/apt/sources.list.d/playonlinux.list sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys E0F72778C4676186 , sudo apt-get update && sudo apt-get install playonlinux

    official wine ppa

  • sudo add-apt-repository ppa:ubuntu-wine/ppa && sudo apt-get update&& sudo apt-get install wine1.5

share|improve this answer
    
None of these work. I keep getting the dependency errors in one form or another. –  pgrytdal Oct 22 '12 at 22:35
    
try to complitely remove wine package with:sudo dpkg --remove --force-remove-reinstreq and reinstall it with sudo apt-get install wine ? Maybe try to download wine package ( this one is 64 bit) packages.ubuntu.com/en/quantal/wine1.4-amd64 and install every dependency listed in terminal ( depends on wine1.4-i386 for example). I recommend using gdebi manager to install deb files because software manager sometime just cant open it –  polarkatenuchie Oct 22 '12 at 22:44
    
It still didn't work... screencloud.net/v/yvIE –  pgrytdal Oct 22 '12 at 23:15
    
Maybe you're trying to install an outdated version of Wine from some PPA. Please remove the PPA from Software Sources, update, and then try to install Wine again. Have you tried to download wine1.4-common package and every dependency package and install it ? Cause i have wine 1.4 working by simple installing playonlinux latest package from official site playonlinux.com/en/download.html –  polarkatenuchie Oct 22 '12 at 23:24
    
I get dependency errors while trying to install Playonlinux as well. I'm wondering if I maybe installed 12.10 wrongly? Because I have troubled doing updates as well. –  pgrytdal Oct 22 '12 at 23:28

I had the same problem under Pear OS 8. Got the it fix its the packages that are in the system that need updating. But you cant just run the commands you need to use Synaptic Package Manager and redownload the catalogue for wine. Then run sudo apt-get install wine. After you have got all the catalogue rebuilt mine said that it updated 201 catalogues dir. It has to do with x64 bit not installing the proper i386 files. I tried everything wanted to give up but tried that even using the fix commands don't work nor does deleting the information for the packages. Just tell it to download catalogue for wine and the rest of your system then use terminal should work. Good luck

alexis@alexis-Aspire-5738:~$ sudo apt-get install wine
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following package was automatically installed and is no longer required:
  gir1.2-timezonemap-1.0 libllvm3.2:i386 libpciaccess0:i386
  libtxc-dxtn-s2tc0:i386
Use 'apt-get autoremove' to remove it.
The following extra packages will be installed:
  binfmt-support fonts-droid fonts-horai-umefont fonts-unfonts-core
  gnome-exe-thumbnailer icoutils imagemagick imagemagick-common
  libasn1-8-heimdal:i386 libasound2:i386 libasound2-plugins:i386
  libasyncns0:i386 libavahi-client3:i386 libavahi-common-data:i386
  libavahi-common3:i386 libcapi20-3 libcapi20-3:i386 libcomerr2:i386
  libcups2:i386 libdb5.1:i386 libdbus-1-3:i386 libdrm2 libdrm2:i386
  libencode-locale-perl libexif12:i386 libexpat1:i386 libffi6:i386
  libfile-listing-perl libflac8:i386 libfont-afm-perl libfontconfig1:i386
  libfreetype6:i386 libgcrypt11:i386 libgd2-xpm:i386 libgif4 libgif4:i386
  libgl1-mesa-glx:i386 libglapi-mesa:i386 libglib2.0-0:i386 libglu1-mesa:i386
  libgnutls26:i386 libgpg-error0:i386 libgphoto2-2:i386 libgphoto2-port0:i386
  libgpm2:i386 libgssapi-krb5-2:i386 libgssapi3-heimdal:i386
  libgstreamer-plugins-base0.10-0:i386 libgstreamer0.10-0:i386
  libhcrypto4-heimdal:i386 libheimbase1-heimdal:i386 libheimntlm0-heimdal:i386
  libhtml-form-perl libhtml-format-perl libhtml-parser-perl
  libhtml-tagset-perl libhtml-tree-perl libhttp-cookies-perl
  libhttp-daemon-perl libhttp-date-perl libhttp-message-perl
  libhttp-negotiate-perl libhx509-5-heimdal:i386 libice6:i386
  libieee1284-3:i386 libilmbase6 libio-socket-ssl-perl libjack-jackd2-0:i386
  libjbig0:i386 libjpeg-turbo8:i386 libjpeg8:i386 libjson0:i386
  libk5crypto3:i386 libkeyutils1:i386 libkrb5-26-heimdal:i386 libkrb5-3:i386
  libkrb5support0:i386 liblcms1:i386 libldap-2.4-2:i386 liblqr-1-0
  libltdl7:i386 liblwp-mediatypes-perl liblwp-protocol-https-perl
  liblzma5:i386 libmagickcore5 libmagickcore5-extra libmagickwand5
  libmpg123-0:i386 libncurses5:i386 libnet-http-perl libnet-ssleay-perl
  libnetpbm10 libnss-winbind libodbc1 libogg0:i386 libopenal1:i386 libopenexr6
  liborc-0.4-0:i386 libosmesa6 libosmesa6:i386 libp11-kit0:i386 libpam-winbind
  libpcre3:i386 libpulse0:i386 libroken18-heimdal:i386 libsamplerate0:i386
  libsane:i386 libsasl2-2:i386 libsasl2-modules:i386 libselinux1:i386
  libsm6:i386 libsndfile1:i386 libspeexdsp1:i386 libsqlite3-0:i386
  libssl1.0.0:i386 libstdc++6:i386 libtasn1-3:i386 libtiff4 libtiff4:i386
  libtiff5:i386 libtinfo5:i386 libusb-0.1-4:i386 libusb-1.0-0:i386
  libuuid1:i386 libv4l-0:i386 libv4lconvert0:i386 libvorbis0a:i386
  libvorbisenc2:i386 libwind0-heimdal:i386 libwrap0:i386 libwww-perl
  libwww-robotrules-perl libx11-6:i386 libx11-xcb1:i386 libxau6:i386
  libxcb-dri2-0:i386 libxcb-glx0:i386 libxcb1:i386 libxcomposite1:i386
  libxcursor1:i386 libxdamage1:i386 libxdmcp6:i386 libxext6:i386
  libxfixes3:i386 libxi6:i386 libxinerama1:i386 libxml2:i386 libxpm4:i386
  libxrandr2:i386 libxrender1:i386 libxslt1.1:i386 libxt6:i386
  libxxf86vm1:i386 netpbm odbcinst odbcinst1debian2 unixodbc winbind
  wine-gecko2.21 wine-gecko2.21:i386 wine-mono0.0.8 wine1.6 wine1.6-amd64
  wine1.6-i386:i386 winetricks
Suggested packages:
  libterm-readline-gnu-perl libterm-readline-perl-perl imagemagick-doc
  autotrace curl enscript ffmpeg gimp gnuplot grads hp2xx html2ps libwmf-bin
  mplayer povray radiance sane-utils texlive-base-bin transfig ufraw-batch
 rng-tools:i386 libgd-tools:i386 gnutls-bin:i386 gphoto2:i386 gtkam:i386
  gpm:i386 krb5-doc:i386 krb5-user:i386 libvisual-0.4-plugins:i386
  gstreamer-codec-install:i386 gnome-codec-install:i386
  gstreamer0.10-tools:i386 gstreamer0.10-plugins-base:i386 libdata-dump-perl
  jackd2:i386 liblcms-utils:i386 libcrypt-ssleay-perl libmyodbc
  odbc-postgresql tdsodbc unixodbc-bin libportaudio2:i386 libroar-compat2:i386
  pulseaudio:i386 hpoj:i386 hplip:i386 libsane-extras:i386 sane-utils:i386
  libsasl2-modules-otp:i386 libsasl2-modules-ldap:i386
  libsasl2-modules-sql:i386 libsasl2-modules-gssapi-mit:i386
  libsasl2-modules-gssapi-heimdal:i386 libauthen-ntlm-perl dosbox:any
Recommended packages:
  libgl1-mesa-dri:i386 xml-core:i386 wine1.5-amd64 wine1.5-i386:i386
  unixodbc:i386 wine-mono0.0.8:i386
The following NEW packages will be installed:
  binfmt-support fonts-droid fonts-horai-umefont fonts-unfonts-core
  gnome-exe-thumbnailer icoutils imagemagick imagemagick-common
  libasn1-8-heimdal:i386 libasound2:i386 libasound2-plugins:i386
  libasyncns0:i386 libavahi-client3:i386 libavahi-common-data:i386
  libavahi-common3:i386 libcapi20-3 libcapi20-3:i386 libcomerr2:i386
  libcups2:i386 libdb5.1:i386 libdbus-1-3:i386 libdrm2:i386
  libencode-locale-perl libexif12:i386 libexpat1:i386 libffi6:i386
  libfile-listing-perl libflac8:i386 libfont-afm-perl libfontconfig1:i386
  libfreetype6:i386 libgcrypt11:i386 libgd2-xpm:i386 libgif4 libgif4:i386
  libgl1-mesa-glx:i386 libglapi-mesa:i386 libglib2.0-0:i386 libglu1-mesa:i386
  libgnutls26:i386 libgpg-error0:i386 libgphoto2-2:i386 libgphoto2-port0:i386
  libgpm2:i386 libgssapi-krb5-2:i386 libgssapi3-heimdal:i386
  libgstreamer-plugins-base0.10-0:i386 libgstreamer0.10-0:i386
  libhcrypto4-heimdal:i386 libheimbase1-heimdal:i386 libheimntlm0-heimdal:i386
  libhtml-form-perl libhtml-format-perl libhtml-parser-perl
  libhtml-tagset-perl libhtml-tree-perl libhttp-cookies-perl
  libhttp-daemon-perl libhttp-date-perl libhttp-message-perl
  libhttp-negotiate-perl libhx509-5-heimdal:i386 libice6:i386
  libieee1284-3:i386 libilmbase6 libio-socket-ssl-perl libjack-jackd2-0:i386
  libjbig0:i386 libjpeg-turbo8:i386 libjpeg8:i386 libjson0:i386
  libk5crypto3:i386 libkeyutils1:i386 libkrb5-26-heimdal:i386 libkrb5-3:i386
  libkrb5support0:i386 liblcms1:i386 libldap-2.4-2:i386 liblqr-1-0
  libltdl7:i386 liblwp-mediatypes-perl liblwp-protocol-https-perl
  liblzma5:i386 libmagickcore5 libmagickcore5-extra libmagickwand5
  libmpg123-0:i386 libncurses5:i386 libnet-http-perl libnet-ssleay-perl
  libnetpbm10 libnss-winbind libodbc1 libogg0:i386 libopenal1:i386 libopenexr6
  liborc-0.4-0:i386 libosmesa6 libosmesa6:i386 libp11-kit0:i386 libpam-winbind
  libpcre3:i386 libpulse0:i386 libroken18-heimdal:i386 libsamplerate0:i386
  libsane:i386 libsasl2-2:i386 libsasl2-modules:i386 libselinux1:i386
  libsm6:i386 libsndfile1:i386 libspeexdsp1:i386 libsqlite3-0:i386
  libssl1.0.0:i386 libstdc++6:i386 libtasn1-3:i386 libtiff4 libtiff4:i386
  libtiff5:i386 libtinfo5:i386 libusb-0.1-4:i386 libusb-1.0-0:i386
  libuuid1:i386 libv4l-0:i386 libv4lconvert0:i386 libvorbis0a:i386
  libvorbisenc2:i386 libwind0-heimdal:i386 libwrap0:i386 libwww-perl
  libwww-robotrules-perl libx11-6:i386 libx11-xcb1:i386 libxau6:i386
  libxcb-dri2-0:i386 libxcb-glx0:i386 libxcb1:i386 libxcomposite1:i386
  libxcursor1:i386 libxdamage1:i386 libxdmcp6:i386 libxext6:i386
  libxfixes3:i386 libxi6:i386 libxinerama1:i386 libxml2:i386 libxpm4:i386
  libxrandr2:i386 libxrender1:i386 libxslt1.1:i386 libxt6:i386
  libxxf86vm1:i386 netpbm odbcinst odbcinst1debian2 unixodbc winbind wine
  wine-gecko2.21 wine-gecko2.21:i386 wine-mono0.0.8 wine1.6 wine1.6-amd64
  wine1.6-i386:i386 winetricks
The following packages will be upgraded:

this should be what you see after using synaptic to download the catalogues the new ones are the missing ones that wont install when you try to do it any other way

share|improve this answer
    
Man, you need to use some punctuation in your posts. It's very difficult to read. –  Danatela Mar 17 at 4:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.