Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an Acer Aspire 3690 laptop who's ethernet adapter is not working due to IRQ conflict with the mouse (report during F1 to continue or F2 to setup). I tried to see and change settings in setup but there is not much other than boot menu that can be changed and could solve the broblem.

I've installed Ubuntu 12.04 but the wireless driver is not working. When running the additional drivers app, it does reports that it wants to install the Broadcom STA wireless driver, but I have no ethernet connection to at least install the correct drivers for the wireless adapter.

Any ideas how to fix my dilemma?

share|improve this question

Have you tried changing the IRQ settings in your BIOS (hitting F2)? The IRQ conflict isn't going to go away on its own.

If you can't change it, you can try a couple of different things:

  • Move your mouse to a different USB port (ideally, one on the opposite side of your computer, so you get a different USB controller)
  • Try a different mouse (if you can get your hands on one, and your computer has a port, try a PS/2 mouse)
  • Go to Broadcom's site, on a different computer, and see if they have the Linux drivers for your card. Download them to a USB drive or CD and install it that way.
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.