Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have just started using Okular and I love it. It has a lot of functionality that I need when I am in pdfs and it already opens up epubs automatically. How to I get it to open pdfs by default instead of "Document Viewer?"

I appreciate the help!

share|improve this question

5 Answers 5

up vote 11 down vote accepted

According to here, Right click the file of the format you want, select properties:

enter image description here

Go to the open with tab, select the program you want to be the default for that type of file, then press the button Set as Default:

enter image description here

share|improve this answer
    
Brilliant. Thank you everyone for your input. –  LibraryGeekAdam Oct 23 '12 at 13:31
    
This only works when opening the file from the file manager, not when opening it from another program like Calibre. –  systemovich Sep 24 at 19:49

In short, if I remember correctly :

  • Right click on a PDF,
  • Properties,
  • Open with,
  • Select an app,
  • Set as default.
share|improve this answer

First open a terminal and use this command:

gedit ~/.local/share/applications/defaults.list

After opening it, Under the [Default Applications] section add a line like this

application/pdf=okular.desktop;

Now save the file and exit gedit.

share|improve this answer
1  
I'd add a note to make a backup first. –  hexafraction Oct 22 '12 at 21:02

In Ubuntu 14.04, the file you need to edit is :~/.local/share/applications/mimeapps.list

The name of okular may varies. Someone may also find that there is no "Set as default" button.

So follow these steps:

Step 1: Right click on any pdf file => Open with => find Okular

The name of okular applications now should be specified in mimeapps.list. Now move to step 2.

Step 2: gedit ~/.local/share/applications/mimeapps.list

Step 3: Find okular in [Added association] and copy to [Default application] section.
In my case, it is 'application/pdf=kde4-okularApplication_pdf.desktop;'

And you are done.

share|improve this answer

Well, none of the other answers worked on 14.04, Okular simply doesn't show up in the list. But this worked perfectly:

mimeopen -d myfile.pdf

It will give you a list of applications that can open the file, and will also update the default application for you.

$ mimeopen -d myfile.pdf
Please choose a default application for files of type application/pdf

1) Print Preview  (evince-previewer)
2) Xournal  (xournal)
3) MuPDF  (mupdf)
4) Adobe Reader 9  (AdobeReader)
5) GIMP Image Editor  (gimp)
6) Document Viewer  (evince)
7) Other...

use application

Selecting one of these will set it as the default for application/pdf file types. You can easily set any executable to be the default by using the Other... option:

use application #7
use command: okular
Opening "myfile.pdf" with usr (application/pdf)

Aside: If okular doesn't work, you might want to try entering the full path (usr/bin/okular). You can find out where Okular is located by running which okular.

share|improve this answer
    
Perfect answer! –  systemovich Sep 24 at 20:04
1  
@systemovich I think you can also just put okular instead of the full path, that should solve the problem with mimeopen thinking the application is called usr. –  jmiserez Sep 25 at 1:09
    
I've updated my answer to use okular instead of /usr/bin/okular. This should fix some naming issues in menus where it would otherwise say usr instead of okular. –  jmiserez Sep 26 at 8:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.