Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have downloaded the Ubuntu 12.10 i386 Desktop ISO both via HTTP & Torrent Download. I have attempted the install via CD & Bootable USB (created using YUMI from Pendrive Linux), each using a different ISO (to rule out corruption).

I can boot from CD & USB and use the live Ubuntu, but each time I try to Install it, Ubiquity hangs at the "Preparing to Install Ubuntu" screen. It doesn't matter if i check or uncheck the 'Download updates while installing' and/or 'Install this third party software' options.

I am attempting install on a Dell Inspiron 6000 Notebook (Pentium M 1.60GHz, 2.0GB RAM, 160GB HDD) with an existing Windows Partition. The install from CD worked without incident on my Triple Boot MacBook Pro.

Also, the System Log app will not open, unsure if this is related.

share|improve this question

closed as off topic by vasa1, Kevin Bowen, Eric Carvalho, Nathan Osman, Basharat Sialvi Apr 10 '13 at 0:59

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

I used gnome-disks to mount all partitions, including swap, and this made it proceed much faster. For 13.10, the installer asked if I want to "try to unmount", to which I said no. I then used the "something different" option and manually selected the installation partition which I had previously created. – nobar Oct 27 '13 at 20:23
Another thing that may make things faster is to create the USB with no user storage ("forget on reboot"). – nobar Oct 27 '13 at 20:24
This is a longstanding known bug. Waiting for an official fix is not a solution. Ask Ubuntu seems like a good place to share workarounds. – nobar Oct 27 '13 at 20:29
One comment: I had this trouble. Spent hours on it. When I selected to NOT 'Download updates while installing' and to NOT 'Install this third party software' everything loaded up fine. It's quite easy to correct these two choices after the operating system is installed. – zipzit Nov 21 '14 at 2:42
up vote 4 down vote accepted

According to here:

Update to this......I just tested it again. Tried to reinstall 12.10 over 12.10 and failed. Put in Debian....let it wipe the drive, create partitions, then killed the install. Then a fresh install of 12.10......and in it went.

So it seems to be if you have a clean drive or a failed install to be written to, there's no problem.

No idea why....that just seems to be the way it is.

This seems like a partition cleaning bug, since you can clearly install it on a clean drive or over an installation that failed.

share|improve this answer
Thanks Evandro, I will pop in a clean drive and see how I fair. I'll report back soon. – Cage Oct 22 '12 at 18:07
You were correct Evandro. The installation progressed without problems on a clean drive. I put my original drive back in and this time booted to windows and removed the Linux partition (which was on an Extended partition). When I booted from the 12.10 live-usb again the installation progressed past the dreaded 'Preparing to install Ubuntu' screen. Many thanks for your superfast and reply – Cage Oct 22 '12 at 18:46
I had this problem on Ubuntu 16. I booted into live mode (had to wait a weird amount of time while it asked for a login and was unresponsive), then used gparted to clean up an old fedora install (I also have windows 10 on my system), and now the install is going as planned. – user3471004 Jul 9 at 17:30

Well, I had the same issue. The way I resolved it was starting up with the live CD and then got into the disk management app, and just format the drive from there. In the option of which file system, I checked the linux file system option. And the installation went very nice.

Thanks a lot!

share|improve this answer
What is the "linux file system option"? – Benedikt Feb 15 '14 at 14:15
This worked for me on 14.x – eebbesen Jan 8 '15 at 3:16

Delete the partitions and make new ones from GParted. That worked for me.

share|improve this answer
I recommend editing this answer to explain how to do that. – Eliah Kagan Jan 31 '13 at 22:20

If you have multiple HDDs and dozens of bootable operating systems,as I have, this is a real problem.

I cannot install 12.04 from CD because it just hangs. There are plenty of clean volumes and previously installed versions, but the installer simply cannot resolve my drives and just hangs. (I have over 3TB of HDD space divided into logical volumes)

The only way to do it is to install 10.04 and then upgrade it to 12.04

Black mark for Ubuntu, by some sort of assumption that all users will be installing to a desktop with just Windoze installed or a previous linux version on a single small HDD, they have completely screwed up what should and used to be, a simple process.

Try installing to a completely virgin HDD and you will get a similar problem, the partitioner does not recognise it until you run fdisk and do rudimentary partitioning.

share|improve this answer

I observed the same issue on ubuntu 13.04.

I was able to work-around the issue by mounting the partitions not needed by the installer.

share|improve this answer
Can you provide more details about what you did and how you did it? – Eliah Kagan Mar 30 '13 at 18:23

Not the answer you're looking for? Browse other questions tagged or ask your own question.