Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed a couple of days ago Ubuntu 12.10 (64 bit).

I today tried ripping a CD in the MP3 format.

However, whenever I try to rip, it says it is missing an extra multimedia plugin "Gstreamer extra plug-ins (i386)".

I then try to install the :i386 version of the gstreamer-ugly plugins, but then I get the same problem but with the id3-demuxer (or something similar)

The Terminal output I get from both problems (but replace the "MPEG-1 Layer 3 (MP3) encoder" with the "ID3-demuxer" name) is:

james@clefairy:~$ rhythmbox

(rhythmbox:24122): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
Rhythmbox-Message: Missing plugin: gstreamer|0.10|rhythmbox|MPEG-1 Layer 3 (MP3) encoder|encoder-audio/mpeg, mpegversion=(int)1, layer=(int)3
/usr/lib/python2.7/dist-packages/gobject/constants.py:24: Warning: g_boxed_type_register_static: assertion `g_type_from_name (name) == 0' failed import gobject._gobject

It doesn't help that each time I have to install/remove the entire Gstreamer-ugly collection each time - I can't find that specific file.

The CD plays fine, it's the ripping plugin that doesn't seem to work.

I didn't have this problem previously on 12.04 (64 bit).

share|improve this question

4 Answers 4

up vote 2 down vote accepted

Have a look at mc4man's post at http://ubuntuforums.org/showthread.php?t=2080739. Looks like we need to use a custom setting. Worked for me.

share|improve this answer
4  
The solution is: Go to Edit > Preferences > Music Change 'Format settings' to 'Custom Settings'. I kept Quality on 4 and sounded fine. –  jfy133 Nov 24 '12 at 17:37
    
@PaulB Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Oyibo Nov 25 '12 at 7:23

Try installing Synaptic and then install gstreamer0.10-plugins-ugly-multiverse If it still doesnt work i would recommend installing LAME (mp3 encoding front-end)

I suggest using Synaptic, simply because it tends to do better at installing technical items

share|improve this answer
    
Thanks for the reply! Strangely enough, I can't find that package under the Multiverse The closest I can get to is 'gstreamer0.10-plugins-ugly'?? I've installed LAME and I'll try reinstalling the package above. –  jfy133 Nov 17 '12 at 14:14
    
Still no luck... any other ideas? –  jfy133 Nov 17 '12 at 14:20
    
check to make sure Sound Juicer is installed (a front end for cd ripping). I think Rhythmbox uses it. Getting tired of all these front-end dependencies? (: I don't know what else may be the issue..after googling it there doesn't seem to be much documentation on it eh? –  The Doctor Nov 17 '12 at 19:30
    
I installed Sound Juicer separately and that worked fine. Rhythmbox is just broken for some reason. Strange. But yes, very little documentation. I did find a couple of bug reports on Launchpad with the same problem, wasn't solved though. bugs.launchpad.net/ubuntu/+source/gst0.10-python/+bug/1070517 –  jfy133 Nov 18 '12 at 15:06
    
Sorry! I hope they get fixed soon! –  The Doctor Nov 18 '12 at 19:02

Open synaptic, install libmp3lame0 then reboot. You should now be able to rip to mp3 after starting Rhythmbox

share|improve this answer
    
Thanks for the suggestion. I already had it installed albeit 'manually'. I removed it, installed it again and rebooted. This time when Rhythmbox said there was a plug-on missing, it did start to install it. However it disappeared before it had finished (seemingly). I now get this terminal output (see next comment): –  jfy133 Nov 20 '12 at 10:29
    
(rhythmbox:2973): GLib-GObject-CRITICAL **: g_object_unref: assertion G_IS_OBJECT (object)' failed Rhythmbox-Message: Missing plugin: gstreamer|0.10|rhythmbox|MPEG-1 Layer 3 (MP3) encoder|encoder-audio/mpeg, mpegversion=(int)1, layer=(int)3 /usr/lib/python2.7/dist-packages/gobject/constants.py:24: Warning: g_boxed_type_register_static: assertion g_type_from_name (name) == 0' failed import gobject._gobject Rhythmbox-Message: Missing plugins installed. Updating plugin registry ... –  jfy133 Nov 20 '12 at 10:32
    
(rhythmbox:2973): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed Rhythmbox-Message: Missing plugin: gstreamer|0.10|rhythmbox|MPEG-1 Layer 3 (MP3) encoder|encoder-audio/mpeg, mpegversion=(int)1, layer=(int)3 (ignoring) Rhythmbox-Message: All missing plugins are blacklisted, doing nothing –  jfy133 Nov 20 '12 at 10:32

Dunno if you're still having this issue but I've used dagrab for grabbing tracks and lame for mp3 encoding. I made a rip-script years ago that I recently re-wrote as I suddenly needed to rip loads of CDs.. It runs fine on my ubuntu 12.04 64-bit. I've not added any uninstall menu-option yet and the PROXY settings don't work with the cddget (perl) I use nowadays BUT otherwise.. it seems to work fine http://www.nollettnoll.net/nenRip/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.