Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

just upgraded to Ubuntu 12.10. I can't reach the desktop, it is stuck on the blue screen, the desktop environnement does not load. Only gnome with no effects works.

Can you help please?

config: thinkpad T400, 6 GB of Ram, graphic card: Intel Gma 4500Mhd

lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)

I am not sure I have not messed up lightdm / gdm previously...

edit: I just tried a 12.10 live usb version and it works it is a problem in my install for sure.

share|improve this question
maybe I did not understand your problem correctly ... You could not see the login screen ? Or you could see the login screen, but, after logging in, you got a blue screen ? – josinalvo Oct 24 '12 at 1:42
indeed, I can login, and after the login screen I only see the desktop and no bars at all – louis Feb 5 '13 at 14:12

I had a similar problem after upgrading. You can follow what I did. Check the ~/.xsession-error logs. If you have errors similar to this: (update-notifier:2286): Gtk-WARNING **: Theme parsing error: gtk-widgets-assets.css:494:61: Unrecognised image file format , then reinstall libgdk-pixbuf2 and type the following as root user

gdk-pixbuf-query-loaders --update-cache and then reboot. If that does not suffice, install gdk-pixbuf2.0-dev and run the above command again. Reboot to see the changes. Hope your problem is resolved.

share|improve this answer

i would also try to reinstall ubuntu desktop with sudo apt-get install --reinstall ubuntu-desktop and execute this command sudo dpkg-reconfigure xserver-xorg at console wich you can summon by pressing cntrl alt f1 then just login with username and password and run the commands

share|improve this answer
Thanks @user85872 I did that and now I see the desktop files but no top and side bars... and also I see a compiz error quit unexpectedly. – louis Oct 22 '12 at 19:40
you should try: sudo apt-get install --reinstall unity or summon the terminal by pressing cntrl+alt+t and type: ccsm if compiz settings manager not installed yet follow instructions there is sugested command in terminal to install it.After install is finished search for ubuntu 'unity plugin' in ccsm and see if it checked as enabled in options – polarkatenuchie Oct 22 '12 at 19:41
I installed compiz manager. Unity plugin is activated. Still no bars on the desktop. Same when reinstalling unity. It is weird because when I logout I see the top bar with clock, network, etc... – louis Oct 22 '12 at 20:16
last advice i can give you is to reset unity to default settings by executing this in terminal copy: setsid unity . This is similar to unity --reset command in 12.04 lts wich now doesnt work in 12.10 then try to reset compiz: setsid compiz --replace and restart X Display: Manager: sudo -s setsid service lightdm restart and finaly try: unity --replace – polarkatenuchie Oct 22 '12 at 20:24
When resetting compiz and unity I get a error: libGL error: failed to load driver: swrast. And it is the same for the other commands you mention. – louis Oct 23 '12 at 8:06

just to check if you indeed messed up the lightdm:

1) go to a tty (i.e., press ctrl alt f1)
2) log in
3) run xinit -- :1 (note the spaces! it is, indeed "--(a space):(no space)1")

this might open you a barebones X session (*) Then, at least, you'll know X is working

(*) just a white terminal in a black background.

If it is the case, the simple and ugly solution will be to use another login manager. After that, we can start investigating =P

install some new login managers:

sudo apt-get install xdm lxdm kdm

choose a login manager:

sudo dpkg-reconfigure lightdm

then reboot so that your login manager has a chance to appear

share|improve this answer
thanks @josinalvo, with xinit -- :1 in tty1 I get a black background screen with a with a white terminal (like Xterm)...but I cannot move it eround the screen or anything else... is X working then? – louis Oct 22 '12 at 17:54
yep. X is working – josinalvo Oct 22 '12 at 18:00
ok thank you. Simple effective test. I did what you suggested. I can login but none of the dm (i tried gdm lightdm kdm xdm ) leads to the displaying of the desktop... what should I do now ;-) – louis Oct 22 '12 at 19:29
I forgot to mention. After you change the login manager, reboot so that it has a chance to try to load. – josinalvo Oct 23 '12 at 2:13
(and hope for the best =P) – josinalvo Oct 23 '12 at 2:14

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.