Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a small problem with the new ubuntu 12.10 minimize animation. I currently have a laptop and a desktop, both upgraded from 12.04 to 12.10. The problem shows up only on the desktop. When I minimize a window, instead of viewing the whole window fade and zoom out, the content disappear, and only the bezel complete the animation.

Here is a short screencast that shows the behavior:

Any ideas on where I can look for a solution?

Many thanks in advance. Regards.


Looks like the open source driver works perfectly. The problem is that the performance is not so cool, and some games that push a little the graphic (like torchligt) do not even startup. Linus is right about nvidia...

share|improve this question
you should add the details of your nvidia card as well as the driver version you are using. Have you tried the experimental drivers available such as v304 (install from synaptic) – fossfreedom Oct 30 '12 at 8:30
yes, none of the three nvidia works. The open source one works but it's so slow... – matteosister Oct 30 '12 at 19:00
The same is happening to me with Nvidia drivers . – joelalmeidaptg Nov 25 '12 at 19:31
As i'm also affected by this behavior i filed a bug for it. – user125919 Jan 25 '13 at 2:03

To solve this problem, head to compiz-config -> workarounds and select the option that says "keep a copy of the minimized windows."

I experienced the same problem as you and this was solved.

I hope it works for you.


share|improve this answer

Try this :

  1. Install compizconfig-settings-manager Install compizconfig-settings-manager.

  2. Run CompizConfig and click on Animation.

  3. Go to the "Minimize animation" tab.

For me, the minimize effect is zoom and duration is 220 and of course the enable animation option is checked, on the left hand side.

share|improve this answer
Thanks! it's already set up like that...I think that the problem is related to the nvidia drivers, not a misconfiguration. – matteosister Oct 29 '12 at 19:58
Try and disable the proprietary driver and use the default one and see if the problem is with that also... Just to get an idea about the source of the error being the driver or configuration... – Vikash Singh Nov 1 '12 at 16:08
if you see the main question, after update I've tried. The probelm is that the open source driver is really slow. – matteosister Nov 1 '12 at 20:08

meybe you applied some changes to settings in compiz manager wich causes problems try to reset unity

  • sudo apt-get install dconf-tools

  • dconf reset -f /org/compiz/


  • setsid unity

    and restart Compiz:

  • setsid compiz --replace

also you can try to restart X Display Manager with`:

  • sudo -s setsid service lightdm restart

instructions taken from ubuntuhelpguy :

share|improve this answer
Sorry but this is just reckless, there's no need to destroy his entire environment to do this. – Jorge Castro Oct 22 '12 at 16:34
thanks for your remark but it doesnt destroy anything att all,to destroy enviroment you have to remove unity package & ubuntu-desktop but here its just reseting 'compiz settings' to default wich you can manualy reapply again and restarting unity to default like in 12.04 lts release with- unity reset -command and nothing else – polarkatenuchie Oct 22 '12 at 16:37
I will take your answer as a "last resource". Let's if someone has another idea...thanks! – matteosister Oct 22 '12 at 17:38
thank for your kind reply i did it by myself when i messed system up changing to much settings in compiz manager and it worked perfectly. Actually its 'ubuntuhelpguy' advice as he has partnership with youtube and make tutorials on ubuntu( i posted the link if you hesitate). But hey thank you next time i would think before posting comment to someone needs help.. – polarkatenuchie Oct 22 '12 at 17:43

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.