Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am new on Ubuntu and setting android environment.I googled too much for this problem but nothing is helping !! when I open eclipse and test android sample project I get a error saying "R cannot be resolved"

Error executing aapt. Please check aapt is present at /home/rahul/android-sdks/platform-tools/aapt
Hint: On 64-bit systems, make sure the 32-bit libraries are installed: sudo apt-get install ia32-libs

on trying sudo apt-get install ia32-libs

E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?
share|improve this question
add comment

3 Answers

sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install ia32-libs
share|improve this answer
    
Thank you for this. If you have time to explain why this works (the top line) it would be greatly appreciated. –  Gleasonator Apr 2 '13 at 21:08
add comment

Open your terminal and type this

sudo rm -rf /var/lib/dpkg/lock
share|improve this answer
    
getting rahul@ubuntu:/$ sudo rm -rf /var/lib/dpkg/lock rahul@ubuntu:/$ rahul rahul: command not found rahul@ubuntu:/$ –  Raahul Oct 22 '12 at 15:16
    
Now the lock file is removed. Can you try executing the command sudo apt-get install ia32-libs –  devav2 Oct 22 '12 at 15:18
    
rahul@ubuntu:/$ sudo apt-get install ia32-libs Reading package lists..Done Building dependency tree Reading state information..Done Some packages could not be installed.This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: ia32-libs:Depends:ia32-libs-multiarch but it is not installable E:Unable to correct problems,you have held broken packages –  Raahul Oct 22 '12 at 15:23
    
i am fighting with this problem from 2 days..installed too many packages.. re-installed ubuntu, java, eclipse and android ! but nothing is working –  Raahul Oct 22 '12 at 15:25
    
Ok this is different issue now . you can solve it by typing sudo apt-get install -f –  raaz Oct 22 '12 at 15:27
show 3 more comments

Close synaptic or any other installation program.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.