Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

gnome-screensaver has been vastly simplified for major version 3 and no longer supplies the preferences dialog. It is now only useful for locking the screen and providing an unlock dialog.

I use 12.04 LTS at the moment and am able to install gnome-screensaver version 3.4.1-0ubuntu1 and add it to the XFCE session's application autostart list. gnome-screensaver then works when I select Lock Screen from the panel.

I am, however, unable to configure gnome-screensaver to auto-lock the screen. There is no obvious configuration file or dialog where I can set the timeout.

Right now I use xscreensaver to achieve auto-locking but I don't really care about screensavers, I prefer auto-lock and display suspend via DPMS. Right now xscreensaver doesn't really play well with lightdm on my system - user switching requires the password to be entered twice:

  • user a lock-screen: press New Login
  • lightdm: enter user b password
  • user b xscreensaver lock-screen: enter password again

I should mention that this system was installed as Ubuntu years ago and I've been installing various xubuntu-desktop meta-packages to try out various desktop environments.

Can anyone help me set up gnome-screensaver auto-lock?

share|improve this question
Is there an "outdated" tag for questions? light-locker takes care of this use-case in Xubuntu (except for on those systems where it's buggy, see… ), while gnome-screensaver 1) also requires entering password twice, and 2) can't auto-lock on XFCE without also running gnome-session, see – unhammer Apr 28 at 7:08

Rather than using a configuration front-end to gnome-screensaver that does not exist, use the xfce4-power-manager via the xfce4-power-manager-settings to lock the screen. Specify a timeout to your liking.

If this does not work for you, install the package dconf-tools, run dconf-editor and edit the items under org/gnome/settings-daemon/plugins/power to your liking.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.