Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Possible Duplicate:
My computer boots to a black screen, what options do I have to fix it?

A few days ago, I upgraded to 12.10. No problems during installation other than two or three errors saying that it was trying to upgrade to something that was already install. So it finished, and asks me to reboot. I reboot, pass grub with no problems, loads up the purple screen from grub, and then hangs on a black screen.

I have tried going into recovery mode, with no luck. I have tried going to lower kernel versions with no luck. I did upgrade the kernel to 3.3.6 to stop the constant freezing freezing with Intel HD 4000.

Also, I did try pressing "e" on the grub menu, changing "quiet splash" to "nomodeset" and that doesn't work.

I have a LiveCD with 12.10 handy, and waiting.

share|improve this question

marked as duplicate by Jorge Castro, Marco Ceppi Oct 22 '12 at 15:21

This question was marked as an exact duplicate of an existing question.

Quantal has 3.5.4 kernel version installed by default and the only time i get black screen trying to login in is when i had fglrx drivers enabled( activated) and i forgot to delete them before installing new kernel version.Iam not saying it is the answer on yor issue but i personaly would try to remove fglrx in console. Go to to restore system in grub menu and search for console (before using it fix broken packages):sudo apt-get remove fglrx maybe this will help.

share|improve this answer
Went to recovery screen, went to root, apt-get remove fglrx, says it can't write to some location. But I don't have an AMD card, either. – Imnotanerd Oct 22 '12 at 15:07
it is like that because it need to unmount your drive first. try to fix broken packages (in option menu) and say yes to unmount .. After that go to root and try sudo apt-get remove '....' simmular to fglrx nvidia package - proprietary drivers wich are installed via aditional drivers menu or synaptic. – polarkatenuchie Oct 22 '12 at 15:14
It's been telling me to mount /. I had to unmount it to get some free space for my Windows partition. Is it safe to mount / even with this other partition? – Imnotanerd Oct 22 '12 at 15:40
it is unmounting in recovery mode and for me it was no issues for a whole time i used this option. I was allways able to login after fixing broken packages or using other options in recovery mode wich require to unmount drive.Or else try to summon the console wich is cntrl alt f1( f1 to f5 wich is number of consoles open) while loading to system and if it will work log in and try to remove proprietary nvidia driver package ( search for the name as ati user i only know fglrx )I only guess that issue is in graphic drivers and hope that will help. – polarkatenuchie Oct 22 '12 at 15:50

Not the answer you're looking for? Browse other questions tagged or ask your own question.