Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am unable to install php5-fpm from sudo apt-get install php5-fpm. It says:

No installation candidate.

No .deb repository link available. Does anyone have a solution?

share|improve this question
    
Try to run sudo apt-get update && sudo apt-get upgrade then try to run sudo apt-get install php5-fpm. Here is the package link packages.ubuntu.com/quantal/php5-fpm –  devav2 Oct 22 '12 at 13:08
    
@devav2 If it is working on your ubuntu, can u plz paste your sources.list file content. –  Sanchit Oct 22 '12 at 13:17
    
It is very similar to one provided here ubuntuguide.org/wiki/Ubuntu_Quantal_Repositories with 3rd party repositories added. –  devav2 Oct 22 '12 at 13:38
    
Possible duplicate of askubuntu.com/questions/14685/… –  Eliah Kagan Jan 9 '13 at 13:40

2 Answers 2

You haven't stated the Ubuntu version you are using so this is just a wild guess. You are using the Ubuntu version which doesn't yet include php5-fpm package. This could be for various reasons – one most prominent might be the php5 version – php5-fpm was introduced from some point in time.

You have basically two options here:

  1. Upgrade your Ubuntu to more recent version. You can find the availability of php5-fpm here: packages.ubuntu.com/php5-fpm

  2. Upgrade your PHP version to most recent from my PPA, see the answer in another thread here: How do I install PHP 5.4.0?

share|improve this answer

php5-fpm is available in all supported Ubuntu releases, but is in universe in all of them. Try enabling universe, run sudo apt-get update and then try sudo apt-get install php5-fpm again.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.