Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Would you recommend to install libcupsys2_1.3.9-17ubuntu3.9_all.deb in Ubuntu 10.10?

For getting my printer to work with Ubuntu 10.10 i've read many threads about a suggested workaround.there it's suggested to install libcupsys2_1.3.9-17ubuntu3.9_all.deb so that the canon driver should again do it's work with ubuntu.

But i can't figure out what this package exactly is and like to understand what i do before i install it. in some thread they call it a dummy package, in others it's called a transitional package. However there should have been a reason why the ubuntu developers had deprecated libcupsys. So would you recommend it?

share|improve this question
add comment

2 Answers

up vote 4 down vote accepted

This package doesn't do anything. It doesn't install any files, it just marks libcupssys2 as installed so that the canon package doesn't complain.

All the required files all already installed by the libcups2 package.

BTW, in my last system (10.04) I've been able to install Canon drivers without need to do this trick. Please check the canon site, as it's likely that the last drivers work without it.

share|improve this answer
    
thanks for the answer. the drivers are from 2008 without this libcupsys package they won't install, with it they do. but although it doesn't print. it's curious because i know the printer worked with ubuntu once and the minimum release is used there was 9.10. –  NES Jan 7 '11 at 14:48
    
@Oli: oh, that double negative thing. English speaking people are weird ;). –  Javier Rivera Jan 7 '11 at 14:52
    
bad habit ;) –  NES Jan 7 '11 at 19:12
add comment

Canon PIXMA MP140, Ubuntu 11.04 The system detects it as MP150.

I've downloaded the packages from official Canon website, when I try to install cnijfilter-common_2.80-1_i386.deb , it requires 'libcupsys2' package which is not presented in modern Ubuntu versions. 'libcups2' is used instead. But the Canon package requires 'libcupsys2' exactly, so the package manager shows errors and in fact I still can not install the package from the official website.

Here is a topic about it https://bugs.launchpad.net/ubuntu/+bug/458445

Here I've found the package and it was installed without problems on 11.04 http://launchpadlibrarian.net/25606454/libcupsys2_1.3.9-17ubuntu1_all.deb

But I haven't tested the printer yet. Maybe this post will be helpful for anybody.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.