Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

sudo apt-get install <anything> is not working in my terminal Whenever i try doing it, it displays the following error message:-

Err http://in.archive.ubuntu.com/ubuntu/ precise-updates/main vim-runtime all 2:7.3.429-2ubuntu2.1
  Could not connect to 111.125.139.199:8105 (111.125.139.199). - connect (111: Connection refused)
Err http://in.archive.ubuntu.com/ubuntu/ precise-updates/main vim amd64 2:7.3.429-2ubuntu2.1
  Unable to connect to 111.125.139.199:8105:
Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/main/v/vim/vim-runtime_7.3.429-2ubuntu2.1_all.deb  Could not connect to 111.125.139.199:8105 (111.125.139.199). - connect (111: Connection refused)
Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/main/v/vim/vim_7.3.429-2ubuntu2.1_amd64.deb  Unable to connect to 111.125.139.199:8105:
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
share|improve this question
    
Are you using a hardware firewall? –  hexafraction Oct 22 '12 at 11:57
    
i hope not..this is not my personal system, it's official one ! –  vipin8169 Oct 22 '12 at 12:03
    
have you tried following the suggested actions? (...maybe run apt-get update or try with --fix-missing?) –  Eliran Malka Oct 22 '12 at 12:11
    
yes i did, none helped –  vipin8169 Oct 22 '12 at 12:15
    
@Eliran Malka how to try the latter one.. --fix-missing –  vipin8169 Oct 29 '12 at 5:57

1 Answer 1

up vote 0 down vote accepted

I suspect there's a problem with the archives in the mirror you are using.

Try opening "Update Manager", click "Settings" and on the "Ubuntu software" tab choose a different "Download from" server.

Then check for updates again and then try apt-get install again.

share|improve this answer
    
tried doing this>> sudo apt-get install vim sudo: unable to resolve host l-vverma Reading package lists... Done Building dependency tree Reading state information... Done Package vim is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source E: Package 'vim' has no installation candidate –  vipin8169 Oct 22 '12 at 12:17
    
PS:- i don't know ho to format the comments properly.. ctrl+K simply doesn't work while commenting –  vipin8169 Oct 22 '12 at 12:26
    
please help someone, i am not able to install anything –  vipin8169 Oct 22 '12 at 13:06
    
Did you try changing the server mirror as I suggested in the answer above? –  To Do Oct 22 '12 at 16:03
1  
If that works try copying the /etc/apt/sources.list from the live DVD to your system. Then apt-get update. –  To Do Oct 26 '12 at 13:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.