Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When trying to install the three amd64 debs for the 3.7.0 kernel from: http://kernel.ubuntu.com/~kernel-ppa/mainline/daily/2012-10-22-quantal/

I get this error:

dpkg: dependency problems prevent configuration of linux-headers-3.7.0-999-generic:
 linux-headers-3.7.0-999-generic depends on linux-headers-3.7.0-999; however:
  Package linux-headers-3.7.0-999 is not installed.

It installs and works correctly but leaves me with broken packages in Synaptic. Is this just a bug with how Ubuntu is packaging these latest debs? Or am I doing something wrong?

share|improve this question

closed as too localized by fossfreedom Oct 23 '12 at 15:36

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Did you download and install all the necessary .deb files? Who are you installing the packages? –  Bruno Pereira Oct 22 '12 at 11:07
    
I install all three of the amd64 debs. There doesn't seem to be any place to get the linux-headers-3.7.0-999 deb. –  James Ward Oct 22 '12 at 11:15
    
I think you are changing the order of execution. First install linuxheaders..._all.deb then linuxheaders...-generic.deb then linuximage...-generic.deb –  devav2 Oct 22 '12 at 11:43
    
That might be the problem. There's no linuxheaders..._all.deb on the server for the 3.7 kernel. –  To Do Oct 22 '12 at 12:16
    
Yup. There is no linux-headers package there. Only the generic one. So, back to my original question... Is this a bug with how Ubuntu is packaging these debs? –  James Ward Oct 22 '12 at 15:14

1 Answer 1

Looks like this was just a temporary issue. The latest build now has the missing linux-headers-3.7.0-999_3.7.0-999.201210230406_all.deb file.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.